Vnl 780 d13 2013 70kmiles vibrations and rocking sound at stop/roll

Discussion in 'Volvo Forum' started by adreanis, Apr 23, 2013.

  1. adreanis

    adreanis Bobtail Member

    19
    3
    Apr 7, 2013
    CHICAGO, IL
    0
    Hi guys, I have a 2013 VNL780 with D13 500hp I-shift EcoTorque since Nov last year. I've been team driving west and east coast all winter, awesome truck very responsive and economic. Recently I've been forced to do really hard break full stop (fully loaded). Ever since then I hear a rocking sound every time I roll from complete stop. Is like the tractor moves about an inch from trailer and hits like a small bump underneath mostly at passenger side or when I brake on downhill pulls a bit right and rocks. When at 42-50mph all my dash and steering wheel are vibrating roughly. I've done 3 axle alignment at Petro and still have same problem. I tried to drive in neutral at 40-50mph and it still vibrates. I checked visually all nuts and bolts that I can think of for being loose and could not find any. Yesterday I took the truck to Omaha Volvo and even they could not find anything wrong. (but I overheard they guy was saying that they r not certified to work on drive shafts so I got charged 100$ for nothing). The truck is under warranty.

    Did anyone have this kind problems? Any advice to guide those geniuses at dealer?

    Also I have a repeating code SA 0 SPN 84 FMI 19. Does not affect the driveability of the truck so its just the check engine light that annoys me the most. It comes ON at slow speeds usually when is cold outside or when I'm backing or rolling off the dock. If I turn the ignition key ON and OFF for about 10 times it goes away. I took the truck to 8 different dealers and they still cant figure it out whats wrong. They erase the codes and say so far that might be a faulty temperature sensitive speed sensor.They replaced the speed sensor and wiring but still comes on once in a while. Last time when I talked to Volvo Corporate HQ they said to take the truck back to dealer and replace the whole ECM module. It remains to be seen if this will work.

    Thank you in advance for your time to answer!!!
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. nasriza

    nasriza Road Train Member

    2,046
    1,618
    Feb 1, 2013
    Chicago, IL
    0
    Check if you're front shocks are leaking it also sounds more like a front tire is out of balance that's the first two things I would check
     
  4. adreanis

    adreanis Bobtail Member

    19
    3
    Apr 7, 2013
    CHICAGO, IL
    0
    Tires were checked when doing alignment and had no unusual wear also just washed the engine today and no sign of shocks leaks.
     
  5. nasriza

    nasriza Road Train Member

    2,046
    1,618
    Feb 1, 2013
    Chicago, IL
    0
    Try see if you could replace the shocks we've had that happen to our trucks a few times we change the shocks and it usually takes care out it
     
  6. adreanis

    adreanis Bobtail Member

    19
    3
    Apr 7, 2013
    CHICAGO, IL
    0
    Will do tomorrow, thank you
     
  7. BrianE

    BrianE Light Load Member

    164
    78
    Mar 9, 2013
    Livingston Texas
    0
    Do you have leaf springs on the rear? If so, are the U bolts tight or the center pin on the leaf?
     
  8. 04 LowMax

    04 LowMax Medium Load Member

    421
    231
    Feb 3, 2013
    Alberta
    0
    ,
    I am wondering if you don't have 2 separate issues going on here The first one sounds like a loose fifth wheel, either jaws or when you did the hard brake, something else came a bit loose with the mounting. As far as the vibration goes, if it comes through the steering wheel and dash, rather than the seat and floor, it is most likely coming out of the front end. How many km on those steering tires?
     
    Last edited: Apr 24, 2013
    adreanis Thanks this.
  9. boneebone

    boneebone Road Train Member

    2,104
    2,010
    Mar 13, 2009
    0
    Are your front tires balanced? Install a set of Centramatics Wheel Balancers on the Steers.
     
  10. adreanis

    adreanis Bobtail Member

    19
    3
    Apr 7, 2013
    CHICAGO, IL
    0
    Just came off TA, they dont have centramatics that fit the new volvo steer brake drums. So no luck there, I will have to find balancing beads or something. 110 000km on steers bridgestones from factory. Checked the rear leaf springs and they look centered with no signs of scrub or rust underneath anywhere. No oil leaks on all shocks no loose bolts that I can see on front and rear suspension.
     
  11. fortycalglock

    fortycalglock Road Train Member

    5,950
    6,090
    Jun 25, 2011
    Tourist Town, FL
    0
    I'm going to guess you have a warped or damaged front brake drum.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted