Volvo D13 sudden loss of power

Discussion in 'Ask An Owner Operator' started by Snowman55372, Jan 26, 2021.

  1. Snowman55372

    Snowman55372 Bobtail Member

    8
    6
    Jan 26, 2021
    0
    While driving down the road I keep losing all power the truck will go to idle. Pushing on the Excelerator or leading off the Excelerator and reapplying it doesn’t help. If I put it in neutral shut the key off wait for 10 seconds turn the key back on and start the truck it runs fine. Has continually gotten worse to the point where every five minutes it will do the same thing. I limped didn’t do a shop in the codes that were in the computer we’re four a bad turbo. This is a D 13 volvo with a variable vein turbo. Anybody else have the same problem
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. 86scotty

    86scotty Road Train Member

    2,489
    5,766
    Aug 27, 2017
    Appalachia
    0
    Try posting in the Volvo forum and you'll get more replies.

    But, if the codes are for a bad turbo then maybe you have a bad turbo.

    What year and how many miles?
     
    Snowman55372 Thanks this.
  4. Snowman55372

    Snowman55372 Bobtail Member

    8
    6
    Jan 26, 2021
    0
    It is a 2011 VNL 630 with 900k on it. D13 motor. Just bought the truck and it was a mistake. Have already put over 10k into it. Including def del
     
  5. 86scotty

    86scotty Road Train Member

    2,489
    5,766
    Aug 27, 2017
    Appalachia
    0
    You didn't do enough research to know not to buy any truck from about 2007-2012 or so? The absolute worst years for reliability. Sorry you've got to learn that now.

    Read up.

    900k is prime time for a turbo, maybe even a little late.
     
    Snowman55372 Thanks this.
  6. Snowman55372

    Snowman55372 Bobtail Member

    8
    6
    Jan 26, 2021
    0
     
  7. Snowman55372

    Snowman55372 Bobtail Member

    8
    6
    Jan 26, 2021
    0
    How do I post to volvo form. Sorry I’m a newbie
     
  8. 86scotty

    86scotty Road Train Member

    2,489
    5,766
    Aug 27, 2017
    Appalachia
    0
    Forums/trucks (18 wheelers)/commercial trucks/Volvo

    You’ll get more attention there.
     
    Snowmantrucking55372 Thanks this.
  9. Snowmantrucking55372

    Snowmantrucking55372 Bobtail Member

    2
    2
    Jan 19, 2021
    0
    The problem was a bad wire in the turbo actuator. Most likely from the harness not properly secured at the last shop I was at that had to remove the turbo. Will never return to Dan’s Diesel in Sunburg, MN. R&R Truck repair in Albert Lea, MN did an awesome job.
     
    JJ 501 and 86scotty Thank this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted