Volvo Speedometer/cruise gone crazy

Discussion in 'Trucks [ Eighteen Wheelers ]' started by DownNotOut, May 14, 2013.

  1. DownNotOut

    DownNotOut Bobtail Member

    6
    4
    Sep 7, 2012
    Jacksonville, FL
    0
    I have a 2001 VN 770. Signature 500 pre-EGR. EF 13spd. The problem began with cruise control not working properly. In use it would kick out for no appaerent reason.
    I replaced engine speed sensor, TPS and RPM speed sensor. It seemed fine for about 3 weeks then it started over with a twist. The speedo now is very errartic.
    At idle its reading varing speeds from 5-50mph. When driving it fluctuates up and down. The only thing I can think of that could cause this is the actual
    dash panel itself and the ECM. Both parts are very expensive so before moving forward I am calling on some advise from my fellow drivers and techs.
    Fire away with your suggestions please. Thank You
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Heavyd

    Heavyd Road Train Member

    7,415
    5,742
    Feb 4, 2009
    0
    Probably just a bad speed sensor at the transmission.
     
    DownNotOut Thanks this.
  4. DownNotOut

    DownNotOut Bobtail Member

    6
    4
    Sep 7, 2012
    Jacksonville, FL
    0
    Already replaced... Next lol
     
    cetanediesel Thanks this.
  5. jameslawton

    jameslawton Light Load Member

    257
    65
    May 1, 2013
    Tulsa OK
    0
    is the speedo the only thing that's acting up could be a yoke nut loose on tranny also the wires run along the tranny to the ecm they can rub and get some corrosion in them and act up just follow the speed sensor wires up to the ecm and pull the cover off the wires see if u can find a bad spot but I would guess a loose yoke nut is probly the problem if you don't have any check engine lights
     
    DownNotOut Thanks this.
  6. ahmadali04

    ahmadali04 Bobtail Member

    28
    6
    Jan 30, 2011
    0
    I had a similar problem on my old volvo truck. I took it to Volvo, and it turned out be a motor behind the speedometer, that controls the gauge, that was starting to go bad.
     
    DownNotOut Thanks this.
  7. nasriza

    nasriza Road Train Member

    2,218
    1,819
    Feb 1, 2013
    Chicago, IL
    0
    Check the wires going to speed sensor make sure they're not running on transmission also check the sensor connector make sure it doesn't look burned up or corroded if possible put some dielectric grease before plugging back in definately do this before getting under dash if you can maybe get a used dash from a junk yard just to test it out instead of just buying new
     
    DownNotOut Thanks this.
  8. cetanediesel

    cetanediesel Medium Load Member

    470
    186
    Mar 26, 2013
    Albany, NY
    0
    Did you do the dash self test?
     
  9. GrapeApe

    GrapeApe Road Train Member

    2,215
    2,185
    Jan 7, 2013
    0
    I second the yoke nut, we had a Pete acting similar, it was just a loose trans yoke.
     
  10. DownNotOut

    DownNotOut Bobtail Member

    6
    4
    Sep 7, 2012
    Jacksonville, FL
    0
    Thank You to All for your help. I have found and resolved the problem. I went ahead and purchased a speed sensor to replace since it was a nomial price of less than $30.
    While replacing it and inspecting the yolk I began tracing the wires. only had to go back about 4 inches from the sensor to see where the problem was. Yep wire had rubbed enough insulation of to cause it to short when the truck would bounce. Sometimes touching sometomes not. This was the cause of the intermitan speedometer and cruise conttrol issue. Hope this help someone else in the future and again I thank all. Be Safe Out there. Your loved ones need you Home.
     
    Heavyd, cetanediesel and robbak11 Thank this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted