HOW TO FIX KENTWORTH T700 ULTRA SHIFT STUCK IN NUETRAL (AUTOMATIC)

Discussion in 'Kenworth Forum' started by PrettyBoyTrucker, Feb 20, 2016.

  1. baha

    baha Road Train Member

    3,714
    2,274
    Jul 25, 2013
    ga
    0
    If you think it is stuck in gear you just need to rock it with key on gear switch in N to get pressure off clutch so it can shift into N, any other truck can hook a strap or chain to your truck and pull a bit back and let it roll back you will hear it click into N, or you can cross starter with wire to move truck a bit, if its not shifting into gear while truck is standing still you need to adj. clutch its just worked by the ecm if its out of adj. it will act like it is doing now sometimes.
     
    PrettyBoyTrucker Thanks this.
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. tech10171968

    tech10171968 Medium Load Member

    627
    848
    Nov 16, 2009
    Daytona Beach, FL
    0
    When my old carrier was running International Junkstars we had the exact problem you desccribe. XY shifters would crap out at about 50,000 miles or so. Whenever I went to a terminal it seemed like every other truck in the shop was an automatic Cornbinder.
     
    PrettyBoyTrucker Thanks this.
  4. dunchues

    dunchues Medium Load Member

    421
    649
    Mar 23, 2012
    new brunswick
    0
    If it's anything like the ultrashift in my cascadia, there is a way to get the gear indicator to show the fault codes by turning the key on and off some times in some seconds. I can't remember the sequence exactly but if you search the eaton website fault finding section I'm sure it will guide you. When mine stuck in neutral it was a broken wire going into the transmission control unit.
     
    PrettyBoyTrucker Thanks this.
  5. S M D

    S M D Road Train Member

    2,360
    3,330
    Mar 15, 2012
    sacramento ca
    0
    ive had xy shifter problems in the volvo and my columbia years back too.
     
  6. rickybobby

    rickybobby Road Train Member

    4,843
    6,668
    Jul 10, 2010
    greensboro, nc
    0
    Try to un hook the battery cable. Sometimes that helps to reset. Your clutch might be going out.
     
    crb and PrettyBoyTrucker Thank this.
  7. rickybobby

    rickybobby Road Train Member

    4,843
    6,668
    Jul 10, 2010
    greensboro, nc
    0
    Also it can be the speed sensor going bad. I have a automatic. I had to replace that.
     
    PrettyBoyTrucker Thanks this.
  8. PrettyBoyTrucker

    PrettyBoyTrucker Bobtail Member

    40
    9
    Aug 31, 2015
    Raleigh, NC
    0
    I spoke to a different Kentworth dealer he said it is a sensor problem. I may have to replace the current shifter and harnes. You know how much that would cost. Ball park figure?
     
  9. flood

    flood Road Train Member

    3,333
    2,330
    Dec 25, 2010
    0
    no it's not a automatic.... a automatic is what you have in a car, what you have is a AUTO-SHIFT (automated MANUAL transmission) and yes it does have a clutch and the clutch is about $500 more than a normal clutch.. bad clutch and it may not go in to gear, bad clutch actuator and it may not go in to gear
    XY shifter about $1,500 and less than 5 hr's labor..... if they tell you they need to drop the trans to do it RUN because they are just trying to make extra money off you, it can be done without pulling the trans
    harness around $500 installed,
    trans computer about $600
    1 thing to check is your trans has 2 power leads (both with fusses) 1 powers the trans computer (no power the truck will not start) the other powers the shifter (truck will start but will not go in to gear)
     
    Cruisin thru Thanks this.
  10. PrettyBoyTrucker

    PrettyBoyTrucker Bobtail Member

    40
    9
    Aug 31, 2015
    Raleigh, NC
    0
    Been having a little of both problems. The truck starts after it resets & goes into gear. After driving a day or two. It will act up again randomly while I'm driving. Fearing that it may shut off @ a stop light or something. The truck pulls good & cruises on the highway.
     
  11. PrettyBoyTrucker

    PrettyBoyTrucker Bobtail Member

    40
    9
    Aug 31, 2015
    Raleigh, NC
    0
    Woke up this morning the whole thing reset & is not showing any service light. But I'm trying to get it in the shop Monday after I drop this load off.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted