1988 turbo issues

Discussion in 'Western Star Forum' started by n4ane, Nov 19, 2020.

  1. n4ane

    n4ane Bobtail Member

    43
    22
    Aug 28, 2020
    0
    Also I figured out why my pyro wasnt working someone didnt know what they was doing and put the red wire to a bolt holding the gauge in the cluster and the yellow to one terminal and took a random wire over from another gauge I have no idea if it was ground or positive so I rewired it correctly and the gauge doesn't move so now I am just going to order a new one with lead and probe and be done with it I found a isspro gauge I liked that has boost and pyro how much psi should I be? its a isspro r609
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Roberts450

    Roberts450 Road Train Member

    2,049
    3,041
    Feb 6, 2016
    0
    35-40psi for an 855.
     
    n4ane and Oxbow Thank this.
  4. n4ane

    n4ane Bobtail Member

    43
    22
    Aug 28, 2020
    0
    Ok sorry for the extreme delay in replying I took so acetone today and rubbed the paint off and took a picture of the code hopefully this is what you guys needed also installed the new pyro gauge and probe today.
     
  5. n4ane

    n4ane Bobtail Member

    43
    22
    Aug 28, 2020
    0
    20201127_210039.jpg Here is the picture
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted