2000 Freightliner 12.7 operating temp. Running too cold.

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by Rideandrepair, Feb 10, 2021.

  1. Inderjit

    Inderjit Medium Load Member

    322
    358
    Sep 17, 2017
    0
    Did you replace the seals when you replaced the thermostats?
     
    BoxCarKidd and Rideandrepair Thank this.
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. baha

    baha Road Train Member

    3,830
    2,400
    Jul 25, 2013
    ga
    0
    IF you go to the winter cover be sure to leave the pass. side open a bit so turbo can get some cooling air on it?
     
    Rideandrepair Thanks this.
  4. baha

    baha Road Train Member

    3,830
    2,400
    Jul 25, 2013
    ga
    0
    Sorry double trouble?
     
    Rideandrepair Thanks this.
  5. Rideandrepair

    Rideandrepair Road Train Member

    12,207
    36,281
    Aug 8, 2015
    0
    I had just bought 2 thermostats when engine blew. Kit came with 2 new ones. I watched them get put in. Still have 2 new ones. The old ones were from last Truck,I had just replaced them when engine blew. Got them back for spares. History repeats itself. Good to have spares. But the rubber seals dry up. Only got 28k on inframe. I want it to seal rings up good. It’s always ran cold, same with last one.but not this cold.
     
  6. Inderjit

    Inderjit Medium Load Member

    322
    358
    Sep 17, 2017
    0
    There are seals that are inside the housing that wear out and let coolant leak past
    through the rad and over cool the engine. they are down inside the housing.
    More often than not its the seals leaking and there is not a problem with the thermostats.
     
    Rideandrepair Thanks this.
  7. Rideandrepair

    Rideandrepair Road Train Member

    12,207
    36,281
    Aug 8, 2015
    0
    We replaced seals also.
     
  8. Rideandrepair

    Rideandrepair Road Train Member

    12,207
    36,281
    Aug 8, 2015
    0
    07BE4054-2EDD-40E0-9317-A9B155358D6C.jpeg 1D9D43EB-D54E-4904-AA88-7AB56B0C8A2C.jpeg EDD4B7BE-F7D4-4169-A5FD-4B99300CC906.jpeg Ok, finally got to warm weather. It’s 48 degrees. Idling at 1000 rpm. Fan just came on just about 200, Went down immediately to 190, fan shut off, only tan about 15 seconds. Temp went down a little more, now headed back up. Seems normal. Just running cold in cold weather.At an idle, and even cooler running down the road. Runs cool enough that Cab heat is noticeably less. Last pic is with manual fan switch on, after about one minute. That seems a bit too cool.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted