2002 t800 blower!!

Discussion in 'Kenworth Forum' started by Perchie15, Jul 13, 2022.

  1. skallagrime

    skallagrime Road Train Member

    2,882
    7,114
    Apr 10, 2012
    Indiana
    0
    Open up the box at blower, verify its got a good connection there, if that has no power, run direct power to blower to verify it works, if it does work, set up a fuse and relay to an on off switch if you just need heat fast and dont care if its full blast or off
     
    Perchie15 Thanks this.
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Perchie15

    Perchie15 Light Load Member

    110
    42
    Aug 16, 2021
    0

    Yea I definitely have all that. Power coming but not turning on the fan! When I had it straight connected the blower speed switch still turned it low and high. I did put a use it also. I had it all Jimmy rigged just to test it and it worked but soon as I ran the #### wire and switch it didn’t wanna work lol. If it’s a WS switch does that matter? Cuz it’s a basic on off switch too
     
  4. skallagrime

    skallagrime Road Train Member

    2,882
    7,114
    Apr 10, 2012
    Indiana
    0
    Sorry but i dont know what you mean here, pictures or a sketch of what youre talking about might be a help. Ws switch? (Western star?)
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted