2007 volvo d12 black smoke under boost

Discussion in 'Volvo Forum' started by Shmeezy69, Jan 7, 2020.

  1. Shmeezy69

    Shmeezy69 Bobtail Member

    14
    0
    Jan 5, 2020
    0
    Hello everyone, I have a couple questions about my volvo. I've owned it for years, and it's been blowing out black smoke past 15 pounds of boost. I've replaced dozens of parts. Egrs, 1 injector, boost sensor, turbo seals, exhaust manifold and gasket, harness, overhead. The truck runs great no misfires or anything has power fuel mileage isnt the best I'll get around 5.5 with 40k pounds. The only code that's ever popped up is egr value too high besides that I havent had any problems. I would like to see if anyone has any ideas to what it might be?
     
  2. Chubby Fly

    Chubby Fly Light Load Member

    277
    312
    Nov 25, 2019
    0
    if it aint smokin something is broken.
    Black smoke is what seperates the men from the boys.
    does the 07 have dpf?
    IF not remove turbo cooler boot from turbo side and piut shop air to the system and check for leaks on the whole system
    if you have dpf, your dpf is cracked on the innside, but dont worry about that my dpf on my cummins ram has been cracked for 7 years. not fixing it becuase it runs strong a1nd no problems and plus i like the soot stain on the bumper
    5.5mpg isnt bad if you are heavy and on the hammer all the time. nobody knows your driving habits. start with intake leaks. sounds like you might have one
     
  3. Shmeezy69

    Shmeezy69 Bobtail Member

    14
    0
    Jan 5, 2020
    0
    No dpf no after treatment just 2 egrs and a egr cooler. It's been doing it since 500k miles has 890k now I'm just tired of my trailer being black. I'm pretty easy on it no hard foot. If I did hard foot I'd probably get 3-4mpg. It has 465hp it should easily be getting 6's all day for mpg. I've considered getting the egrs deleted tonsee if that will fix the problem
     
  4. Chubby Fly

    Chubby Fly Light Load Member

    277
    312
    Nov 25, 2019
    0
    i run pre egr, but my buddy blocked off his egrs in both his trucks and made a world of difference in everything. could be a number of things with the smoke but givin the mileage i would say you are doing fantastic with the motor. get some pvc from home depot and put a air fitting in it and clamp it to your cac boot on turbo side. Leave everything else hooked up. You should only need about 5 pounds of shop air. Dont put too much into it becuase you will blow the fitting out of the boot. IF you have an air leak good enough to cuase black smoke, you will hear it pissing out where the leak is without spraying everything down with soap
     
  5. Shmeezy69

    Shmeezy69 Bobtail Member

    14
    0
    Jan 5, 2020
    0
    Sounds good I'll try that this weekend when I get back in town. I appreciate it
     
    Last edited: Jan 7, 2020
  6. Chubby Fly

    Chubby Fly Light Load Member

    277
    312
    Nov 25, 2019
    0
    This website will delete the thread if i discuss how to do emissions deletes on here. so that has to be kept private. I dont want your thread to get deleted
     
  7. Phil12

    Phil12 Bobtail Member

    11
    1
    Jan 7, 2020
    0
    It will also smoke if the computer doesn't no where top dead center is. If it has a two wire crankshaft sensor it is probably dirty and needs cleaned . Leave the shim out if it doesnt touch relutor wheel. Also try unplugging intake sensor and see how it runs.
     
  8. Phil12

    Phil12 Bobtail Member

    11
    1
    Jan 7, 2020
    0
    I use a magnet to pull the shavings from the hole.
     
  9. 401-Alex

    401-Alex Light Load Member

    66
    41
    Nov 25, 2013
    401
    0
    Age is probably sticking. I have an 05 670 d12 465 volvo 1.5 mil. On it 5.5 to 6.2 mpg never smokes. The epg that controls the exhaust shudder might be sticking. Closed it has 2 functions one is to be used as an exhaust brake and second is as a backpressure device to increase exhaust to the egr valves. The "twins" as I have read are very problematic.
     
  10. 401-Alex

    401-Alex Light Load Member

    66
    41
    Nov 25, 2013
    401
    0
    A freeze plug in front of the valvecover pipe might fix it?
     
  • Draft saved Draft deleted