2012 Prostar single axle with maxforce engine

Discussion in 'International Forum' started by tompands, Jul 8, 2022.

  1. tompands

    tompands Bobtail Member

    15
    16
    May 29, 2022
    0
    I bought this truck, its a 2012 single axle Prostar with a maxforce engine. The truck starts and runs great. Only has 200k on it. Comes up to temp, has great oil pressure. Everything works in it and has Ice cold AC. To just stand next to it while its running, you would think its a good truck. YOU WOULD THINK ! The truck only does 40 MPH. This shop has had it for 4 months and cant find the problem. First they thought the exhaust was the issue. Clogs in the regen system, whatever. They removed all the exhaust and drove it. 40MPH. Then they thought it maybe in the ECM. Tried a different ECM, still 40MPH. Then they found the Air charger was leaking bad, only building 8-10 PSI. AH HA, we found the problem (we thought). I bought and sent them a new air charger, No change, still 40MPH. He has hooked up his laptop to it and all shows to be good, no codes present. What in the hell could cause this issue? I'm glad I don't need the truck( I bought it to resell), but dam, 4 months and no results, and don't misunderstand me, This guy is a pretty decent wrench, he'll throw a clutch in a truck in 4 hours, build a 60 series, or 3406 with his eyes closed. This is bothering him as much as me. There's like NO obvious issue with the truck. It's almost like the speed is turned down to 40 in the ECM, but it's not, set at 70mph. Any help or suggestions would be appreciated.
     
    Last edited: Jul 8, 2022
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Heavyd

    Heavyd Road Train Member

    7,441
    5,795
    Feb 4, 2009
    0
    Find someone who knows Maxxforce engines and Navistar Engine Diagnostics software. You need to record a performance snap shot and then review the data.
     
  4. Inderjit

    Inderjit Medium Load Member

    432
    464
    Sep 17, 2017
    0
    What engine? The max speed limit can be set in the ECM. If it was ordered with the max speed set to 40mph then the new ECM would get the same speed limit. It could have been ordered as a job-site truck.
     
    Heavyd Thanks this.
  5. buddynewOO

    buddynewOO Bobtail Member

    47
    18
    Aug 10, 2020
    MN
    0
    i saw a Youtube where a guy with the maxforce had the same problem. It turned out to be some kind of sensor on the drivers side of engine. He went to change the thing and found that the plug/wire to it was broken and not connected. Don't remember what the video was called but it shouldn't be too hard to find. just search you tube for Maxforce video's. There are not that many.
     
  6. tompands

    tompands Bobtail Member

    15
    16
    May 29, 2022
    0
    I wish you could remember that video, I looked through a bunch of them and couldn't find it.
     
  7. tompands

    tompands Bobtail Member

    15
    16
    May 29, 2022
    0
    I think it's the 11, He has checked the speed limit in the ECM, it's set at 70mph. This truck was a freight hauler truck. It used to pull doubles.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted