2014 KW T660 Low Beam Headlight Issue

Discussion in 'Kenworth Forum' started by rtttcr, Nov 7, 2021.

  1. rtttcr

    rtttcr Bobtail Member

    6
    2
    Oct 27, 2021
    0
    Hey everyone,

    Just received a low beam fault and can't figure out the issue.

    High beams, blinkers, markers all work fine, and when you switch on the lights or toggle from high to low you can see the low beams flicker and then go out. Occasionally, mostly never at this point, the passenger low beam will stay on, and when it works, it will work for a while while toggling high/low or turning on/off the lights.

    Any recommendations?

    By the way, I have no idea which relay is for the low beams, nothing in the fuse box under the hood or the fuse box in the cab drivers side have any label indicating headlights/lamps.

    Thanks,

    Rick
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. QUALITYTRUCK

    QUALITYTRUCK Road Train Member

    1,636
    1,517
    Jun 14, 2009
    romulus,mi
    0
    You need to locate chassis node module, driver frame rail under driver seat, cut the 432 zip ties on the harness leading to node and inspect wires carefully. Google "K.W. chassis node" if needed.
     
    RubyEagle Thanks this.
  4. rtttcr

    rtttcr Bobtail Member

    6
    2
    Oct 27, 2021
    0
    So sometimes it really is simple, but getting there can take a while.

    I found a wiring diagram and noticed that the low beam on one side shares common with high beam on the other, that pretty much eliminates a ground problem, not entirely, but most likely. I then grabbed the multimeter and checked voltage at the plug, that looked good. After that I tried a new bulb but wasn't optimistic since these bulbs are pretty reliable and for two to go ... and sure enough, didn't help.

    So now I was thinking it must be the ballasts or ignitors for the HID bulbs. I took this off the table at the beginning because I thought no way both ballasts or ignitors would go bad ... well, in fact the issue was bad ballasts. Got on eBay and ordered a ballast/trigger/bulb set for each side and when they arrived I popped in a new ballast on the driver's and finally, there was light. Did the same to the passenger side and it worked as well. Ug!

    -Rick
     
    QUALITYTRUCK Thanks this.
  5. RubyEagle

    RubyEagle Medium Load Member

    354
    277
    Apr 17, 2010
    0
    Yeah it happens. Are the lights shining still? Cancel button on dash and roll on!
     
  6. rtttcr

    rtttcr Bobtail Member

    6
    2
    Oct 27, 2021
    0
    Lights still working :)
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted