2014 T680

Discussion in 'Kenworth Forum' started by TruckerPete1990, Dec 19, 2020.

  1. TruckerPete1990

    TruckerPete1990 Road Train Member

    8,086
    4,368
    Jul 16, 2012
    Rogers Arkansas
    0
    I have a 2014 t680. When turning left anything more then 2 turns my steer tire rubs on the black plastic( the removable black one under the headlight)on the passenger side. It will also do it if im in an unleveled driveway or dock going straight. I can clearly see the rub marks on the plastic.
    I've checked all the bolts and they are in place and tight. I've replaced the shocks up front thinking maybe one was weak and didn't help.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. 062

    062 Road Train Member

    4,278
    8,375
    Oct 20, 2013
    0
    I know nothing about these new trucks. Is it attached to the hood? If so I’d look at hood bushings/mounts.
    @Goodysnap may be familiar with your problem.
     
  4. TruckerPete1990

    TruckerPete1990 Road Train Member

    8,086
    4,368
    Jul 16, 2012
    Rogers Arkansas
    0
    It is attached to the hood.
    Where are the hood bushings?
     
  5. 062

    062 Road Train Member

    4,278
    8,375
    Oct 20, 2013
    0
    There should be bushings where the hood pivots and probably where the hood attaches to the hinges.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted