2016 Western Star 5700XE OEM Headlight problem

Discussion in 'Western Star Forum' started by TXBearCat81, May 24, 2020.

  1. TXBearCat81

    TXBearCat81 Bobtail Member

    8
    0
    Mar 18, 2020
    0
    I purchased a 2016 Western Star 5700 XE and the LED brow around the inside edge of the headlight didn't work on the driver side. So thinking it was the headlight assembly, I purchased a new one (OEM) and install and plugged it in and the brow still doesn't work. The passenger side brow is working fine. Anyone have any idea as to what would cause the LED brow not to work? It's supposed to be on as long as the truck is running.
    Thanks!!
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. olddog_newtricks

    olddog_newtricks Medium Load Member

    440
    1,168
    Jun 3, 2018
    0
    Check your plug and see if any of the contacts look burned or black.
     
  4. TXBearCat81

    TXBearCat81 Bobtail Member

    8
    0
    Mar 18, 2020
    0
    Thanks for responding back so quickly. When I unplugged the headlight, the contacts on the headlight assembly were clean, no rust, or moisture. Could it be the plug to the harness coming from the truck's electrical system? It doesn't look frayed or burnt.
     
  5. olddog_newtricks

    olddog_newtricks Medium Load Member

    440
    1,168
    Jun 3, 2018
    0
    Well it's not getting power. So I would get a test light and start checking all connections in the harness until you find power.
     
  6. TXBearCat81

    TXBearCat81 Bobtail Member

    8
    0
    Mar 18, 2020
    0
    Does the LED Brow light get its power from the same source as the low beam and high beam headlight?
    Thanks,
     
  7. jason6541

    jason6541 Heavy Load Member

    713
    650
    Mar 5, 2012
    around
    0
    Both of mine are out on my 2020 5700xe I guess I could get them replaced under warranty but not something I am going to do. My 2017 5700 also has them out. It came down to wires they were soldered to the led strip solder joint failed.
     
  8. TXBearCat81

    TXBearCat81 Bobtail Member

    8
    0
    Mar 18, 2020
    0
    Thanks for responding. How would they fix that? Is this something that I can do?
     
  9. jason6541

    jason6541 Heavy Load Member

    713
    650
    Mar 5, 2012
    around
    0
    Replace the headlights, but you could try pulling headlights and wrapping in a towel and placing in a oven at about 200 degrees for about 20 min to soften the glue then separate the lenses from the rear housing and check the connections inside. Do at your own risk.
     
  10. TXBearCat81

    TXBearCat81 Bobtail Member

    8
    0
    Mar 18, 2020
    0
    Thanks!
     
  11. RocketyMan

    RocketyMan Medium Load Member

    323
    147
    Jun 5, 2015
    0
    Give me the last 6 of your vin...and I can get you wiring for you to look up instead of just guessing like the others are suggesting.
     
    25(2)+2 Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted