2020 Peterbilt 579 stereo issues

Discussion in 'Trucking Electronics, Gadgets and Software Forum' started by Lee68013, Sep 15, 2019.

  1. Lee68013

    Lee68013 Bobtail Member

    3
    1
    Sep 15, 2019
    0
    Is anyone else having issues with the stereo freezing up. When this happens I have to stop and pull the fuse to get the unit to power down. It freezes if its on or off. It doesn’t seem to matter. Peterbilt has replaced the unit but it still does this Daily.
     
  2. Collie

    Collie Guest

    same #### thing happens with my dodge. Except for me, i have to disconnect the battery and wait. I love all this new junk. Its allllllll junk.
     
  3. jtaran06

    jtaran06 Road Train Member

    1,321
    1,356
    Dec 23, 2007
    western ky
    0
    Yes. 2020 579. Had 700 miles on it. Radio frozen. Pulled it out and pulled power cord for 5 min. So far so good.
     
  4. Rounded_nut

    Rounded_nut Light Load Member

    92
    103
    Feb 25, 2018
    0
    Can't help with the issue, but rather than pulling the fuse, push in the volume knob and hold the home button for about 6 seconds then release. This forces it to reboot. My 2016 does this often, I hate smartnav.
     
    jtaran06 Thanks this.
  5. Lee68013

    Lee68013 Bobtail Member

    3
    1
    Sep 15, 2019
    0
    We have 4 brand new trucks every truck has the same issues with the stereo and the only thing that helps is to remove the fuse. Even when you shut the truck off if the stereo is frozen it will not power down. One of the other truck once it’s been shut off for about 30 min all of the exterior light come on and off. The driver pulled every fuse and relay for the lights and this continues to happen unless the batteries are disconnected
     
    Aamcotrans Thanks this.
  6. Lee68013

    Lee68013 Bobtail Member

    3
    1
    Sep 15, 2019
    0
    We don’t have the smart nav just the regular concert class stereo receiver
     
  7. jtaran06

    jtaran06 Road Train Member

    1,321
    1,356
    Dec 23, 2007
    western ky
    0
    Guys at my place run mostly those Pete's and have had a ton if trouble they said. Lots of them new cascadia been showing up.
     
  8. Rounded_nut

    Rounded_nut Light Load Member

    92
    103
    Feb 25, 2018
    0

    Ah!
     
  9. 98 star car

    98 star car Light Load Member

    77
    31
    Jul 25, 2015
    Avon, Indiana
    0
    The forced re boot option just worked on mine. Ty
     
    Lee68013 Thanks this.
  • Draft saved Draft deleted