95 pete 379 cruise control problem

Discussion in 'Trucks [ Eighteen Wheelers ]' started by leo319, Dec 22, 2011.

  1. Diesel Dave

    Diesel Dave Last Few of the OUTLAWS

    5,013
    5,767
    Jan 20, 2010
    Hesperia, Ca.
    0
    Did you replace the clutch switch like I stated earlier ? The brake switch I reckon would be only if your brake lights weren't working, but not 100% sure.
     
    Oxbow Thanks this.
  2. leo319

    leo319 Light Load Member

    66
    3
    Jul 13, 2011
    monterey bay, ca
    0
    ok so i replaced the brake switch already and nothing happening. i called the original owner and he said to mess with 2 of the speed sensors on the tranny. he said he did that a couple of times and solved this problem. and that all this happened when he put the 18 speed on it. My speedometer and tach are working fine. Any idea to check if theyre good before i replace them? Could this even be the problem?
     
  3. Troy001

    Troy001 Bobtail Member

    1
    0
    Feb 2, 2018
    0
    Will the brake lights still operate even if this switch goes bad? My cruise quit awhile back. It used to be intermittent. Then one day it quit, I reset it and about a half mile later it quit again. Six times like that and it just quit period. The only thing I haven't changed is the brake switch, clutch switch and harness. I'm running out of options. It'll throw a code but all it says is switch failure.
     
  4. pushbroom

    pushbroom Road Train Member

    1,138
    3,748
    Sep 1, 2012
    0
    There are two seprate brake switches, one for the ecm and one for the brake lights. Clutch switch is the most common. Year/ vin.
    High idle work?
     
  5. mslashbar

    mslashbar Medium Load Member

    501
    572
    Jul 22, 2009
    elizabeth,co
    0
  6. stayinback

    stayinback Road Train Member

    3,700
    7,496
    Jan 24, 2014
    chicago,il
    0
    Im Chasing Mine Also.....But I Went Further, I Replaces Clutch Switch- Speed Sensor- Cruise switches(on/off set resume) AND Clockspring.. STILL NO CRUISE- Will Not Kick idle up-Nothinh-

    I Did Not replace Brake switch Because Brake Lights work and no air leaks.

    Its a 2001 FORD with a C12. Now, Last Nigt I used a Screwdriver to Up the Idle while I Slept (pryed it between the Dasah and Throttle pedal... In The Morning, I Removed the Screwdriver But it stayed idled at whae I Set it at last Night..I Had to hit the "Off" Switch to go back down to normal idle.

    Is Thewre something in the accelerator Pedal Sticking For Cruise ??
     
  7. Fryman2018

    Fryman2018 Bobtail Member

    1
    0
    Jul 12, 2018
    0
    1992 Peterbilt 378. First start it up you can set the cruise to idle. Once you apply the brakes and start driving all cruise options shut off. What is the problem??
     
  8. Manuel cardona

    Manuel cardona Bobtail Member

    2
    0
    Oct 2, 2018
    0
    Replaced brake switch and clutch switch and once I reach 65mph the cruise control cutoffs
     
  9. Kray4439

    Kray4439 Bobtail Member

    12
    20
    Dec 10, 2018
    0
    I know this is an old thread, but my cruise will only work when brakes are pressed. Brake switch bad?
     
  • Draft saved Draft deleted