Code 13 fuel temp sensor not working

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by AL617, Oct 1, 2022.

  1. AL617

    AL617 Bobtail Member

    7
    3
    Mar 4, 2021
    0
    Today my c15 mxs giving me code 13 , fuel temp sensor not working, I installed a new temp sensor 3 month ago and the code came back today. Usually when when I keep my rpm steady if I throw it in neutral the engine light goes away .. usually happens once a day around my last run always.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Gliding ProStar

    Gliding ProStar Medium Load Member

    602
    4,495
    Nov 12, 2016
    Waxahachie, Texas
    0
    The first thing to know and understand about engine diagnostics is that just because you have a DTC set for a certain part it does not mean that the part has failed. Several other things come in to okay like wiring, voltage to the sensor, sensor ground and sensor reference and signal to the ECM.

    If I remember correctly DTC 13 is for fuel temp sensor volts too high. This could be from a failed sensor but you need to verify the sensor ground and verify the sensor voltage.
     
  4. spsauerland

    spsauerland Road Train Member

    4,291
    10,847
    May 31, 2010
    West Harrison, In
    0
    Voltage too high on two wire temp sensor is usually due to an open circuit.
     
  5. Gliding ProStar

    Gliding ProStar Medium Load Member

    602
    4,495
    Nov 12, 2016
    Waxahachie, Texas
    0
    Correct, voltage too high can be caused by an open circuit or a short to voltage. It's pretty simple to diagnose whether or not you have the correct voltage.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted