Cruise control issues?

Discussion in 'Kenworth Forum' started by tnpete, Jul 10, 2020.

  1. tnpete

    tnpete Medium Load Member

    541
    558
    Jun 25, 2013
    Tn
    0
    This is about to drive me mad. I know my wife tells me I'm almost here now. But my Cruise works at times, and others not going to work. Been fighting this for a while. Well after waking up with legs cramps at 3am from mashing that skinny peddle 9 hrs yesterday. :mad: Thought you fool, you know what is the reason not the cause. Yesterday at I did one thing different.
    Let me start over, I'm pulling a Dump trailer with electric brakes with my 1995 T600. So not pushing in the trailer valve. That valve for some reason has started leaking air when not used. But tractor valve is pushed, so need to rebuild it I think? But if I push in the trailer valve and back out while holding the tractor valve in. That stops the air leak, but also shuts the cruise off?? But let that small air leak keep leaking and cruise works perfect.
    Now Jake's work and high idle works every time. Just the cruise issue when I stop the leak. So today I made 4 loads and cruise worked perfect. Other then the time I tried to make sure it was the trailer valve causing the issue. So sure enough with the leak stopped no works. But let it leak works like it should.
    So anything else that could be making this happen? Or do I need to just pull the valves out and find a rebuild kit for them? Had a truck doing this years ago, and it was the the valves.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. SmallPackage

    SmallPackage Road Train Member

    1,419
    3,354
    Dec 20, 2019
    Marion Texas
    0
    My guess is with the screwy valve it has the cruise function in the ecm thinking you are still parked with no leak. With the leak air is flowing so that tricks it into thinking park is not set and you are rolling.
     
    650cat425 Thanks this.
  4. tnpete

    tnpete Medium Load Member

    541
    558
    Jun 25, 2013
    Tn
    0
    Still not found out the reason. But Cruise worked every load last week. Don't like the small leak, but better then craps in my leg all night. Going to get the valve rebuild this coming weekend. 42 more loads and can park it for a week.
     
    SmallPackage Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted