Led headlights 389 issues

Discussion in 'Peterbilt Forum' started by joey0921, Nov 7, 2018.

  1. pushbroom

    pushbroom Road Train Member

    1,722
    6,986
    Sep 1, 2012
    0
    WDHC4S57RE20 is the module.
    520s have the same cecu setup as 389s so id like to think it would work fine. Never have the chance to try one yet. The last page of the install has a wiring digram. Connectors will not match, will need to be modified
     

    Attached Files:

    KB3MMX and spsauerland Thank this.
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. 2010Pete389

    2010Pete389 Bobtail Member

    1
    0
    Jun 27, 2021
    0
    I installed a set of United Pacific projection headlights part # 31646 and #31645 on my 2010 389 everything installed great, I have 2 turn signal sockets and the UP headlight only came with one plug so my other socket just screwed into the headlight. Turn signals worked fine but when I turned on the headlights and turn signals the dash indicator for the turn signals quit blinking and just stayed on, turn signals were working fine. Any ideas why this is happening?
     
  4. pushbroom

    pushbroom Road Train Member

    1,722
    6,986
    Sep 1, 2012
    0
    Led turn signals need to get enabled in the cecu. Dealer should be able to program it
     
    spsauerland Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted