Lost Heat and everything,?

Discussion in 'Kenworth Forum' started by RTR, Jan 22, 2020.

  1. RTR

    RTR Light Load Member

    174
    33
    Nov 29, 2011
    Alabama
    0
    Need some help and advice.

    07 T600 Cat C-15,
    1,313,134

    2 nights ago my heater and blower stopped working. When I say stopped I mean everything, no blower air in front or back, nothing. Turned truck off, did post trip and then cranked truck back up and everything worked fine.

    Last 2 nights left truck running because of the cold. Yesterday morning it was running fine. This morning not working.

    Came to Shop and cut truck off, went and signed in after 10 minutes came out and tried it started working for 10 minutes and then stopped again.

    Went and got another control module and plugged it in and still nothing?

    I have noticed when it is doing this the AC button you press to activate the bunk is flashing on and off?
     
  2. baha

    baha Road Train Member

    3,193
    1,666
    Jul 25, 2013
    ga
    0
    Have you been driving thru rain before it stopped working? look for water near any plug in, pull all all of them from back to front looking for green on any of conn.. clean with ele. spray cleaner till you find the bad ones?
     
  3. HoneyBadger67

    HoneyBadger67 Road Train Member

    1,211
    2,518
    Dec 15, 2018
    Champaign, IL
    0
    Wiggle the metal fuses (circuit breakers) behind the kick panel when it stops working. Some of these roads can vibrate them loose.
     
    Cabinover101 and RTR Thank this.
  4. RTR

    RTR Light Load Member

    174
    33
    Nov 29, 2011
    Alabama
    0
    Thank you. Come to find out the fuse in the fuse box had worked its way loose.

    Wow never thought about a fuse causing the ac light to flicker on and off.
     
    HoneyBadger67 Thanks this.
  • Draft saved Draft deleted