Maxxforce 10 low power MAF Cal failed

Discussion in 'International Forum' started by fnpanda, Oct 11, 2021.

  1. fnpanda

    fnpanda Bobtail Member

    10
    1
    Oct 11, 2021
    0
    I'll start by saying I dont own or drive an 18 wheeler but I am really struggling for help. I have a maxxforce 10 in my motorhome. It died on the side of the road but was running great prior to that. I had to towed to international dealer and they wanted 30k and had a laundry list of stuff to replace. They replaced the HPOP since it wasnt building pressure. Motor was able to run again but hasnt been the same since. It has a 6 speed allison and is a dog in 4-6.

    Ive replaced
    EGR Cooler had a coolant leak
    EGR valve
    EGR Mixer duct ( was fused to egr valve)
    Converted to open breather
    Cleaned L/H turbos
    I've run every diag test and all pass except I cant do MAF Calibration. I get SPN 1209:0
    MAF Cal throws code when notice surging? out the exhaust
    I tested BCS and wastegate actuator.

    Anyone have any thoughts? I'd really appreciate them (other than get rid of it) as Ive heard that too many times.
    Much appreciated.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Opus

    Opus Road Train Member

    9,288
    36,743
    Dec 18, 2011
    South GA
    0
  4. Heavyd

    Heavyd Road Train Member

    7,269
    5,472
    Feb 4, 2009
    0
    That code is for exhaust back pressure too high. Check the exhaust back pressure valve to make sure it isn't stuck in the closed position. This valve is located right after the turbos. It has an air cylinder and when the rod is extended, the valve is closed. The normal position is open, so you should not see this rod extended. After that you might have a plug DPF/DOC so disconnecting the exhaust at the inlet to the DOC and retesting would confirm this if you get your power back.
     
    stuckinthemud and QUALITYTRUCK Thank this.
  5. bonder45

    bonder45 Road Train Member

    1,097
    2,629
    Oct 2, 2011
    Williston, ND
    0
    You should have gotten it deleted instead of replacing all the EGR stuff....
     
  6. fnpanda

    fnpanda Bobtail Member

    10
    1
    Oct 11, 2021
    0
    Thanks for the responses. Deleting or swapping isnt in the cards for me. Just trying to improve the shortcomings as best I can. I tested the back pressure valve with 8 and 21.5 psi and it worked as specified. I had looked at the doc and dpf earlier and the looked great (to me, no cracks or melting) The DPF did have a heavy amount of soot that seem to be collecting along the gap where the filter media meets the cannister. I will try to separate the down pipe where it meets the doc and retest today.
     
  7. ChuckMartel

    ChuckMartel Light Load Member

    137
    79
    Jan 22, 2021
    0
    Any chance you can have a 0-60 and Air Management Test snapshot recorded and post it here?
     
  8. fnpanda

    fnpanda Bobtail Member

    10
    1
    Oct 11, 2021
    0
    I do, hopefully this is allowed?
    I sure do.
     
  9. fnpanda

    fnpanda Bobtail Member

    10
    1
    Oct 11, 2021
    0
    Ok so Im pretty upset now. I pulled the crossover duct to see if it was clogged and its fine. BUT, there's moisture pooled up in the egr cooler. Its brand new with only 5hrs maybe on it. Could I have caused something for a new cooler to fail?
     
  10. ChuckMartel

    ChuckMartel Light Load Member

    137
    79
    Jan 22, 2021
    0
    Hey sorry I forgot to check the snapshots out, Tuesday I can. As for the moisture, is it coolant or just water? You can get condensation in the EGR system due to temp changes.
     
  11. fnpanda

    fnpanda Bobtail Member

    10
    1
    Oct 11, 2021
    0
    Looked like clear sooty water not coolant. So it looks like its most likely condensation, sorry for the panic. I ran the motor with the crossover off and it dried up.

    I apologize for being all over the place but I may have made a discovery.
    Test 1: Ran MAF Cal with doc but no DPF.
    EPB too high, noticed significant exhaust blowby on EGR cooler where it meets exhaust manifold seals. Shutdown test immediately after that.
    I confirmed wastegate and EBP valve were not extended during test

    Test 2: Ran MAF Cal with No DOC or DPF
    It ran a little better (no blowby) but I notice "fluttering" sound from tailpipe while at full load. I could visibly see the exhaust come out of the 3" tube in "quick puffs"? Then throws code EPB above desired and test fails.
    I confirmed wastegate and EBP valve were not extended during test

    I have no idea if this is helpful, but any insight is much appreciated.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted