Month 2 problem #2

Discussion in 'Volvo Forum' started by Computertrucker, Feb 5, 2014.

  1. Computertrucker

    Computertrucker Light Load Member

    80
    25
    Sep 7, 2013
    0
    So bought this Volvo last month. 2014 780 love it. HOWEVERHad a regen issue and a fuel economy issue a week after purchase. Got that fixed.

    Now to month 2 and see if anyone has experienced this. It goes in the shop tomorrow when I go home.


    First off my engine fault light is on but it's not giving a code. However this is where it gets Wierd. This started 2 days ago. If I turn on my headlights. My tractor ABS light turns on, my TCS light turns on, and my hill start assist light turns on. Also my speedometer drops to 0, my fuel economy gauge drops to zero, and wait for it.....my engines rpm drops to 500 rpm and loses all power. I have to pull over and restart the truck and it resets. But if I turn on my head lights or parking lights even, it does it again. I thought it may be the trailer so I disconnected the pigtail and it's still doing it.


    Sooo.. Has anyone ever experienced anything like this? I am hoping this is the last of my new truck bugs... Keeping fingers crossed. Other than that this truck is absolutely amazing.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. fencitup

    fencitup Light Load Member

    225
    111
    Jan 12, 2014
    Bronx, NY
    0
    What was the regen problem, and how did they fix it?
     
    xiipercent Thanks this.
  4. luvtotruck

    luvtotruck Road Train Member

    1,978
    1,159
    Jul 30, 2013
    Phoenix Arizona
    0
    Yikes! I think something is messed up, So how long do you get to drive? Before it does this? Or does it do it when the lights(either) are turned on?
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted