No idle AC prostar problems

Discussion in 'International Forum' started by Twista89, Jun 27, 2022.

  1. Twista89

    Twista89 Light Load Member

    86
    38
    Oct 2, 2017
    0
    So recently I had my ac serviced and had all batteries, some jumper wires, and fuses replaced and for a month everything was fine. Now I seem to have a problem with the no idle system on my prostar not cooling. Everything turns on, evaporator motor, condenser fan, no idle ac light, all works but when I go to touch the ac lines going into the bunk they are not cold at all. Also noticed my voltage is barely dropping now. Is the compressor in the bunk done?
     
    Last edited: Jun 27, 2022
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Heavyd

    Heavyd Road Train Member

    7,415
    5,745
    Feb 4, 2009
    0
    If you have the type with the bigger 150 amp relay, there should be big 4 wire connector that powers your compressor controller. There should be power at the two red wires, and ground at the white ones. This is fused from the cube type fuses at the extra set of batteries usually behind the bunk in between the frame rails or side saddle battery box. To check for power to the compressor, you need to access the compressor and you will see three wires going to it, blue orange and yellow. Each of these should have about 6 volts being cycled to them each.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted