Peterbilt 579 Headlight Problem - High Beams

Discussion in 'Ask An Owner Operator' started by Brandon0928, Jun 12, 2024.

  1. Brandon0928

    Brandon0928 Light Load Member

    184
    105
    May 14, 2022
    0
    I have a 2018 579 Pete. Issue I’m having is with my high beams. When I turn on the high beams for the first time they will stay on “bright” up until there’s enough oncoming traffic and have to switch to dim. When I switch back to the brights 1 of 2 things happen. 1. Brights will come on for approximately 30 seconds and automatically switch to dims. 2. Brights won’t come back on at all. I have to shut off the headlights then brights work again. Replaced the headlight wiring harness. Replaced the turn signal switch. Have looked over the wires going to the node to no avail. Anybody else run into this problem ?
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. boneebone

    boneebone Road Train Member

    2,256
    2,295
    Mar 13, 2009
    0
    Newer trucks have a LCM (Light Control Module) which controls how the lights operate.

    The module may be defective or may need to be reprogrammed by the Stealership or someone with the software to do so.
     
    Long FLD Thanks this.
  4. Long FLD

    Long FLD Road Train Member

    10,016
    39,297
    Mar 4, 2015
    0
    I second the idea of getting the computer hooked up to make sure everything is as it should be.
     
  5. snowwy

    snowwy Road Train Member

    20,035
    12,614
    Jul 6, 2009
    0
    3rd.

    I know a 2020 that had to replace that module just to get his lights working.

    All he had was one running light right and one headlight left.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.