Rig Master APU

Discussion in 'Prime' started by wannaBTrucker, Jul 13, 2012.

  1. Yves kanevil

    Yves kanevil Medium Load Member

    522
    442
    Jan 10, 2016
    Nighthawk
    0
    I have a first gen rigmaster. Must be one of the few good ones 18 thousand hours and still going.
     
    Chucktshoes Thanks this.
  2. Skate-Board

    Skate-Board Road Train Member

    3,747
    3,869
    Aug 9, 2014
    Merrimack, NH
    0
    I've had mine since 2006. If it quit today I would buy another one. Normal stuff went wrong but that's true of any APU. If you don't keep up with repairs it can get overwhelming. I've also been replacing side panels that get rusted. Replaced motor mounts. Just because you spent $8k or more doesn't mean it's going to last forever. Repair what you have. It's much cheaper then buying another one.
     
    redoctober83 and darthanubis Thank this.
  3. RubyEagle

    RubyEagle Light Load Member

    158
    53
    Apr 17, 2010
    0
    Huh. I had an old ### Ringmaster worn out that came with my last truck. All rusted out etc. Would crank but not start. We finally cut the generator belt and turns out the generator was seized up or something but it started. Let us know if you figure it out. Thanks for the info.
     
    archangelic peon Thanks this.
  4. Dominion Transportation

    Dominion Transportation Light Load Member

    126
    55
    Jul 3, 2013
    0
    Got the new unit as well. Oil pressure low? Try tightening the crimp on the wire going to fuel solenoid. Worked for me. The folks at rigmaster are working on an update for extra time before a/c compressor kicks in when you start unit on auto on for fan. Like it other than evaporated temp sensor going bad and going thru air filters quickly.
     
  5. Dominion Transportation

    Dominion Transportation Light Load Member

    126
    55
    Jul 3, 2013
    0
  6. redoctober83

    redoctober83 Road Train Member

    2,384
    2,200
    Sep 10, 2013
    Seattle, wa
    0
    What did you do? Not run turn it on? Lol
     
    bzinger Thanks this.
  7. Dominion Transportation

    Dominion Transportation Light Load Member

    126
    55
    Jul 3, 2013
    0
    Ours was installed properly at BusnTruck Strafford, Mo.
     
    darthanubis Thanks this.
  8. Skate-Board

    Skate-Board Road Train Member

    3,747
    3,869
    Aug 9, 2014
    Merrimack, NH
    0
    As with any unit it has to be maintained. The Rigmaster has 3 things that effect it running quiet. The #1 is the air cleaner housing. Sounds strange but sucking air is very loud if it's not a tight fit. Exhaust manifold cracked and missing insulation.
     
    redoctober83 and darthanubis Thank this.
  9. archangelic peon

    archangelic peon Medium Load Member

    429
    285
    Dec 15, 2011
    0
    After more shop visits with no luck we went on vacation & left truck in Springfield terminal with APU running for them to work on with hope the dam thing would throw the fault codes & it finally did...shop said the engine speed sensor was faulty & replaced it; also evidentially needed a belt shim kit & since they did both those things no more squealing belts (which it has done since new) & functions properly as of a week or so since......hallelujah

    Maybe we can finally make it to 1000hrs & the first oil change.

    BTW, thermoking reefers & Tripacs both use Yanmar engines, & you can get the (closed loop cooling) option on Tripac which does not tie into the truck engine coolant or oil.
     
    Last edited: Oct 19, 2016
  • Draft saved Draft deleted