T660 keeps shutting off

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by jmlloar, Jul 21, 2019.

  1. jmlloar

    jmlloar Light Load Member

    90
    10
    Jun 13, 2009
    Ridgeley, WV
    0
    I have a T660 tractor that keeps shutting off.
    Shuts down like turned off key, when this happens I lose tach and speedo and eng hours and odo go to dashes. only other gauge affected is dpf level. It goes to zero and light flashes. after a few min everything goes to normal and it runs fine for sometimes a few min up a few hours then it starts all over again.

    checked batt cables and ground and hot connectors at batt and everything is clean.

    This is my only truck and its killing me having it broke down. ANY help is greatly appreciated.
     
  2. jmlloar

    jmlloar Light Load Member

    90
    10
    Jun 13, 2009
    Ridgeley, WV
    0
    Sorry,
    2013 T660 double bunk aero
    last 6 336239
     
  3. Goodysnap

    Goodysnap Road Train Member

    1,380
    2,458
    Jul 12, 2017
    0
    You have a bad connection. And are losing ECM power and maybe aftertreatment controller power intermittently.

    By check battery cables you mean visually? Take them all apart wire brush all terminals and load test all batteries separately.

    If you have the ability, connect a headlight to the powers and grounds at the ECM shake everything down until you get the light to flicker. This is your best chance at tracking the problem down.
     
  4. jmlloar

    jmlloar Light Load Member

    90
    10
    Jun 13, 2009
    Ridgeley, WV
    0
    loosened and cleaned batt terminals
    pulled twisted and unplugged wires
    pulled relays and replugged them

    ecm has 2 large connectors with no obvious power or ground wire.
     
  5. BoxCarKidd

    BoxCarKidd Road Train Member

    2,390
    2,620
    Aug 26, 2014
    0
    No Kw's that new here but does it have big breakers in the battery box area? When it shuts off check those.
     
  6. Navtech

    Navtech Light Load Member

    57
    41
    May 9, 2019
    0
    Check power supplies to ignition relays if everything mentioned above checks out, verify the pins/terminals are a tight fit.
     
  7. jmlloar

    jmlloar Light Load Member

    90
    10
    Jun 13, 2009
    Ridgeley, WV
    0
    only one breaker in batt box
     
  8. jmlloar

    jmlloar Light Load Member

    90
    10
    Jun 13, 2009
    Ridgeley, WV
    0
    its being a total pita
    never seams to give me enough time to test anything, it just powers back up when I try to test stuff
     
  • Draft saved Draft deleted