thermo king apu En9

Discussion in 'Trucks [ Eighteen Wheelers ]' started by Ezrider_48501, Sep 14, 2011.

  1. Ezrider_48501

    Ezrider_48501 Road Train Member

    2,943
    2,449
    Apr 2, 2011
    bismarck, nd
    0
    i have a thermoking tri pac apu as soon as you try to turn it on it comes on system fault and code En9 can anyone tell me what code en9 means
     
  2. 25(2)+2

    25(2)+2 Trucker Forum STAFF Staff Member

    14,847
    16,378
    Sep 18, 2006
    the road less travelled
    0
    There is a reset button on a box under the bunk, mine is on top of that box. If the engine doesn't start and stay running, the reset gets tripped and the code is displayed. any time the engine stops without the controller shutting it down, the reset will probably trip.

    It might be tryiing to turn on the AC before the engine settles down after starting, stalling it out.
     
    Cummimgs Trucking LLC Thanks this.
  3. Ezrider_48501

    Ezrider_48501 Road Train Member

    2,943
    2,449
    Apr 2, 2011
    bismarck, nd
    0
    the engin is not starting at all the other night i went to sleep and turned the heat on woke up and this code was on and its not even trying to start now. iv tryed pressing the reset button checked all the fueses. when i turn it on the blower fan kicks on for about a half a second then the system shuts down you dont hear the glow plug buzzer or starter or any kind of noise from the apu itself
     
    nofilter Thanks this.
  4. rachi

    rachi Road Train Member

    2,778
    1,682
    Feb 25, 2010
    Truckin' in SoCal
    0
    check for a loose/broken belt. Also check oil level. Some units wont start up if low on oil.
     
  5. Ezrider_48501

    Ezrider_48501 Road Train Member

    2,943
    2,449
    Apr 2, 2011
    bismarck, nd
    0
    oil is just about a 1/4 below the full mark still way above the add mark, next truck stop i stop at ill try toping it off
     
  6. nitrotowing

    nitrotowing Bobtail Member

    1
    0
    Jan 2, 2012
    0
    i have a thermo king api on my 2007 wester star and i getting an en9 code when i reset everything the motor cranks but will not start i can hear the ignition and everything trying to ignight but will trip the breaker after 30 seconds of cranking over
     
  7. apyles

    apyles Medium Load Member

    447
    140
    Oct 21, 2011
    Newbern,Tn
    0
    Those thermo kings have so many fail safe switchs, it could be any number of things. Anything to low oil to a slight voltage reading to to anyone of the sensors. Sometime it will run on a fan settting just fine, then switch it to ac and ikt will throw am engine code. the one i have is very sensitive.
     
  8. Cummimgs Trucking LLC

    Cummimgs Trucking LLC Light Load Member

    108
    77
    Jun 20, 2015
    0
    This helped me. I hit that button on top, and it's running now. Thanks bro
     
    25(2)+2 Thanks this.
  9. Dgdoc

    Dgdoc Bobtail Member

    1
    0
    Oct 4, 2016
    0
    I can't find the reset button under my bunk any guesses where it might be or where under the bunk would it be
     
  • Draft saved Draft deleted