ThermoKing Tripac bogs down when A/C is on

Discussion in 'Ask An Owner Operator' started by MyLotion, Aug 2, 2020.

  1. MyLotion

    MyLotion Bobtail Member

    8
    3
    Aug 20, 2019
    0
    Hello everybody, I was wondering if anyone could help me on this problem. I have a 2006 Thermoking Tripac Yanmar 270 that I just recently added A/C to. A brand new condenser, drier, condenser fan, and hoses. Everything runs fine with the A/C off, but once the A/C compressor kicks on and the condenser fan turns on, the engine starts to bog down and run really rough but doesnt come to a halt. If anyone has any ideas, please let me know. Thank you very much.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. JonJon78

    JonJon78 Road Train Member

    4,317
    19,705
    Jul 1, 2018
    0
    Sounds like a weak alternator possibly?
     
    MyLotion Thanks this.
  4. MyLotion

    MyLotion Bobtail Member

    8
    3
    Aug 20, 2019
    0
    I replaced the alternator as well, my apologies for not stating that. It was a thermoking original part not an ebay one
     
    JonJon78 Thanks this.
  5. Spyro2112

    Spyro2112 Light Load Member

    281
    148
    Mar 17, 2018
    0
    It will a little, turn up the idle if possible,
     
  6. MyLotion

    MyLotion Bobtail Member

    8
    3
    Aug 20, 2019
    0
    Idle is already at max
     
  7. JonJon78

    JonJon78 Road Train Member

    4,317
    19,705
    Jul 1, 2018
    0
    Has the fuel filter been changed?
     
  8. MyLotion

    MyLotion Bobtail Member

    8
    3
    Aug 20, 2019
    0
    Yup both fuel filters have been changed along with the oil filter
     
    JonJon78 Thanks this.
  9. MyLotion

    MyLotion Bobtail Member

    8
    3
    Aug 20, 2019
    0
    Brand new fuel pump as well
     
    JonJon78 Thanks this.
  10. Ridgeline

    Ridgeline Road Train Member

    16,225
    65,103
    Dec 18, 2011
    Michigan
    0
    Sounds like the injection pump governor is going bad
     
    Snailexpress Thanks this.
  11. reeferwrencher

    reeferwrencher Light Load Member

    148
    192
    Aug 4, 2018
    0
    Possible bad compressor if it wasn't changed or high head pressure.Do you know how much freon was charged in the system
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted