Ultrashift problem

Discussion in 'Western Star Forum' started by Road*Runner, Jan 2, 2021.

  1. Road*Runner

    Road*Runner Light Load Member

    90
    236
    Jun 14, 2015
    Arkansas
    0
    I have an 07 WS with eaton ultrashift 13 speed. It does not want to shift 2nd to third. After it hits fourth, it works normal. If I shift manual, 2nd and third works fine. I don't know much about this transmission, I was hoping someone could help. I was thinking maybe x-y shifter needs replaced. Also don't know if this has anything to do with it, but it was throwing up code 61, (Detroit 60 14L) which is low voltage on injector. When I started shifting manual through third gear, the code doesn't come on.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. daf105paccar

    daf105paccar Road Train Member

    6,379
    6,874
    Apr 15, 2012
    0
    Have you checked the wire harness?
    Connectors?
     
  4. Road*Runner

    Road*Runner Light Load Member

    90
    236
    Jun 14, 2015
    Arkansas
    0
    Yes looked at that first.
     
  5. Road*Runner

    Road*Runner Light Load Member

    90
    236
    Jun 14, 2015
    Arkansas
    0
    This little solenoid was the culprit. Changed it out and it solved all my issues.
     

    Attached Files:

    jsnell and daf105paccar Thank this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted