VGT

Discussion in 'International Forum' started by Mr Bob, Oct 27, 2023.

  1. Mr Bob

    Mr Bob Light Load Member

    221
    73
    Mar 17, 2015
    0
    Vin 7H466592 DT466E no codes, starts and runs ok for less than a minute. After that, no power, lots of smoke when accelerator pressed, VGT duty cycle stays high, about 93 percent. Passes bounce test, key on actuator cycles and stays put.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Inderjit

    Inderjit Medium Load Member

    600
    596
    Sep 17, 2017
    0
  4. QUALITYTRUCK

    QUALITYTRUCK Road Train Member

    1,775
    1,720
    Jun 14, 2009
    romulus,mi
    0
    If you end up needing a VGT actuator, PM me. I was cleaning stock room and found brand new reman for that truck.
     
    Mr Bob Thanks this.
  5. Mr Bob

    Mr Bob Light Load Member

    221
    73
    Mar 17, 2015
    0
    no active codes now. one egr code popped up but got canceled somehow running tests.
     
  6. Inderjit

    Inderjit Medium Load Member

    600
    596
    Sep 17, 2017
    0
    A failing EGR valve could cause a low boost situation.
     
    QUALITYTRUCK Thanks this.
  7. Heavyd

    Heavyd Road Train Member

    7,616
    6,007
    Feb 4, 2009
    0
    Unplug your egr valve and test this again. If you have Service Maxx software, plug the egr valve back in and run a key on engine off standard test, then run key on engine off output state high and low tests three times each and see if any EGR valve codes pop up. If all good there, try running with the exhaust back pressure sensor unplugged.
     
    QUALITYTRUCK Thanks this.
  8. Mr Bob

    Mr Bob Light Load Member

    221
    73
    Mar 17, 2015
    0
    i unplugged the exhaust pressure sensor and it runs much better.
    program wont let me do a koeo test. :(
    This thing is making me crazy. one moment it barely runs. a few moments later it runs good. no codes, even when i floor it and it slowly just dies. no codes. the only thing i can see goofy in parameters is the VGT offset is high in the 4-5 hundreds and the exhaust backpressure reads sky high koeo.
     
    Last edited: Oct 30, 2023
  9. Mr Bob

    Mr Bob Light Load Member

    221
    73
    Mar 17, 2015
    0
    I was able to scan a similar truck that has similar numbers KOEO. I hate this intermittent stuff. Ran it this morning and it ran good. lol
     
  10. Mr Bob

    Mr Bob Light Load Member

    221
    73
    Mar 17, 2015
    0
    We decided to throw an exhaust backpressure sensor at it cause looking at the data the sensor looked sketchy. it worked for a few weeks. It came back with seemingly the same problem. If I unplug the VGT it runs much better but no VGT power. Everytime I shut it off it will run good for a bit then fail again.
     
  11. Inderjit

    Inderjit Medium Load Member

    600
    596
    Sep 17, 2017
    0
    Any active codes when its acting up?
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted