Webasto heater apu problems

Discussion in 'Questions From New Drivers' started by dboot01, Jan 20, 2022.

  1. dboot01

    dboot01 Bobtail Member

    49
    102
    Nov 8, 2021
    0
    I'm getting really annoyed here. To get the heat working in the truck while the truck is off I have to keep turning the heat on and off until it works because it keeps blinking red and says maintenance required "temperature setpoint" or "sensor position" really annoying when it's super cold out like tonight. It starts working on its own terms it seems like. Any suggestions? Thanks
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Snailexpress

    Snailexpress Road Train Member

    2,504
    5,742
    Apr 28, 2014
    Rocky
    0
    Google webasto manual. Read it.
     
  4. Espressolane

    Espressolane Road Train Member

    10,468
    49,761
    Nov 21, 2009
    Just south of the north 40
    0
    It probably needs an service/overhaul. Full kits are about $180.00.
     
  5. Moosetek13

    Moosetek13 Road Train Member

    12,450
    13,404
    Nov 1, 2010
    Burnsville, MN
    0
    I have the same problem with the Espar in my International LT.
    It has been to 3 shops and no one seems to find the solution.
    The last shop said they rebuilt it, but nothing changed.

    As usual it will probably be something as simple as a sensor that no one thinks to test or replace.

    So I am stuck hoping for cold enough to idle the truck to stay warm, or trying to stay warm with blankets over my head and warm breath.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted