13 speed splitter problem

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by zeljkorikverc, Mar 30, 2020.

  1. zeljkorikverc

    zeljkorikverc Bobtail Member

    19
    3
    Aug 18, 2018
    0
    I have a problem with my 13 speed (RTLO18913A).
    When I'm in 5H and preselect L to go into 6L, occasionally instead of releasing it so I can pull the handle into 6, it shifts back into 5L as soon as I move my leg of the pedal. Of course it makes a big bang every time that happens.

    The whole transmission was rebuilt 2 months ago mostly because of this problem but the shop that did it doesn't know what could be the problem. I have replaced slave valve and it's still happening.

    Does anyone have an idea what could it be???
     
  2. truckdriver31

    truckdriver31 Road Train Member

    4,964
    5,396
    Sep 18, 2013
    0
    yea the shop.
     
    Ribeye and AModelCat Thank this.
  3. swaan

    swaan Road Train Member

    2,854
    4,055
    Jul 12, 2009
    BC canada
    0
    Check your air regulator on rear of trans. I forget what they are set at, maybe 60 psi. Yours could be putting out to much psi. You can try splitting as you shift from 5th to 6th. Don't pre select.
    Or use your clutch like Eaton recommends too.
     
    Bean Jr. Thanks this.
  4. D.Tibbitt

    D.Tibbitt Road Train Member

    6,512
    29,130
    Apr 26, 2013
    0
    Maybe u are too slow . If u are floating u shouldnt give it enough time to shift back. ur foot and arm should be moving at the same time
     
    Hegemeister Thanks this.
  5. D.Tibbitt

    D.Tibbitt Road Train Member

    6,512
    29,130
    Apr 26, 2013
    0
    I have had the same thing happen to me if i am to slow to get the next gear
     
  6. zeljkorikverc

    zeljkorikverc Bobtail Member

    19
    3
    Aug 18, 2018
    0
    I am definitely not to slow, I had other people driving my truck and the same thing happens.
     
  7. Dave1837

    Dave1837 Light Load Member

    297
    604
    Nov 16, 2019
    Pennsylvania
    0
    My 18 spd does the same thing with the same gear. If I pull it out of gear too slow after I pre selected the next gear, it will downshift on its own whenever it's halfway out of gear. Pull it out a little harder and it shouldn't happen. If it does I'd call the place that rebuilt it
     
  8. zeljkorikverc

    zeljkorikverc Bobtail Member

    19
    3
    Aug 18, 2018
    0
    I am pulling it hard because it recently started doing this, when I upshift from 5L to 5H (where I just select and release the pedal) it makes a bang and shakes the whole truck, now that started happening in my 6th gear as well...
    I am taking it back to the shop, I was on a test ride with mechanic last night showing him what and how it happens because it's hard for me to explain. Now he knows what happens but still doesn't know what could be the problem because it doesn't happen every time...
    They will pull it of but I don't know if they will find the fault, that's why I'm trying to get some advice from you guys before they take it in again...
     
    Dave1837 Thanks this.
  9. speedyk

    speedyk Road Train Member

    1,729
    2,232
    Apr 8, 2015
    0
    I've seen the same thing, stopped preselecting the splitter amd all is well, except when I just suck at shifting in general.

    I think some gears have more play so it releases easier in those and lets it shift.
     
    Bean Jr. and HoneyBadger67 Thank this.
  10. AModelCat

    AModelCat Road Train Member

    15,898
    65,314
    Jul 7, 2015
    The North
    0
    If air pressure is good I'd suspect the issue is in the back box. Most likely culprit the teeth on the sliding clutch for the splitter. When they wear (as well as the internal teeth on the gears they slide into) it makes it easier for engine torque to kick it out of mesh.
     
    speedyk, D.Tibbitt and HoneyBadger67 Thank this.
  • Draft saved Draft deleted