Electrical Fault 2016 Prostar

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by BigWheels2012, May 10, 2022.

  1. BigWheels2012

    BigWheels2012 Bobtail Member

    18
    5
    Jun 6, 2020
    0
    Hello guys, Heavy D, if you are out there this is for you! I have a 2016 Prostar with the ISX15 and Eaton 10 speed Auto Trans (Push Button). The truck batteries were low and there was a very slow crank. I hooked a jump box up and still had a slow crank or a low voltage/amp crank. The engine would slowly turn over but not fast enough to fire. After trying several times, the key was left in the crank position for too long resulting in an electrical fault along with ABS module message coming on in the cluster message center. When this happened, the truck will no longer turn over. The batteries were changed, all fuses/relays were checked but still no crank. Truck was scanned, there were codes that made no sense, for example output shaft speed sensor, The codes would clear but come back within 3 seconds using a scanner. The Batteries have been disconnected multiple times over about a week, trying to reset the modules, with no luck. (Electrical fault still shows up) The truck will start if you jump the starter, however the transmission will not engage. The "DRN" (Drive, Reverse, Neutral) only flashes when pressed. I believe the low voltage crank corrupted a module or fried a module, therefor the truck does not know it is in Neutral, therefore it will not crank with the key. I had the truck towed to International. I gave detailed notes of what was going on, however the tech never read them, therefore, spending 3 hours and coming up with a bad starter.........No, it's not the starter, it starts if you add 12 volts to the solenoid, and the transmission doesn't engage or read......After updating him, he says there is not any communication with the TCM. They want another 4 hours to check power and grounds before replacing the TCM. They say there is only 1 TCM in the world and it's in Canada at $5,000 plus $200 for shipping + install and programming and is 2 weeks out. Whoooo Saaaawwww!!!! Question is: Do you think that the TCM itself is fried, electrical issue in the wiring/connections, or is there something else to have checked?
    Also, The dealer was able to find someone to build out a new TCM, however they want 8 hours to R&R the TCM. Does this sound right? From what I see the TCM is just on the side of the trans with a few bolts and 2 connectors. Thanks! Thank you in advance!!!!
     
    Last edited: May 11, 2022
    Reason for edit: update
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Altonburnum

    Altonburnum Bobtail Member

    5
    1
    Jun 2, 2022
    0
    Did you ever get a resolution? My truck is currently doing the same exact thing, word for word.
     
  4. H3R3T1C

    H3R3T1C Light Load Member

    129
    22,825
    Oct 4, 2013
    0
    Well, if its exactly like the above just hard wire one of these remote starters in and your back on the road.

    Let me know if it works, if it does ill send you my bill.
     
  5. Altonburnum

    Altonburnum Bobtail Member

    5
    1
    Jun 2, 2022
    0
    it turns out it was the tcm in our case. we installed a new tcm and recalibrated the grade sensor and she runs like a champ.
     
  6. Ken C

    Ken C Bobtail Member

    5
    2
    May 24, 2022
    0
    Did you get this resolved?
     
  7. Judge

    Judge Road Train Member

    7,505
    45,342
    Mar 19, 2014
    Newport, Ar
    0
    Ken C Thanks this.
  8. Heavyd

    Heavyd Road Train Member

    7,443
    5,798
    Feb 4, 2009
    0
    The original poster did pm me about this and I believe he also had another thread about it. Basically, low voltage cranking fried the transmission TCM. Replaced the TCM and all good.
     
  9. Altonburnum

    Altonburnum Bobtail Member

    5
    1
    Jun 2, 2022
    0
    I did, Thank you. It was the TCM.
     
    Heavyd Thanks this.
  10. Altonburnum

    Altonburnum Bobtail Member

    5
    1
    Jun 2, 2022
    0
    In our case, the battery voltage was very low and insufficient to crank truck. We hooked our 16 volt jump box to it and we believe that 16v jump fried the TCM. Truck couldnt see neutral and locked out the starter.
     
  11. ChuckMartel

    ChuckMartel Light Load Member

    151
    91
    Jan 22, 2021
    0
    Hope you didn’t get charged 8 hours to change. More like 2 including a road test.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted