Trucking Jobs New Driver Jobs Flatbed Jobs Tanker Jobs Refrigerated Jobs Auto Hauler Jobs
Results 1 to 9 of 9
  1. #1
    Light Load Member stlwaco's Avatar
    Member Since
    Oct 2009
    Location
    St. Louis, MO
    Trucker?
    No Answer
    Age
    28
    Posts
    276
    Thanks
    76
    Thanked: 45 Times

    Tow Truck 04 Columbia ecu 128

    I just got in a 04 Columbia today. On the first trip I am broke down. It has a Detroit with a Lightning 10 speed. Pulling out of a rest area, the rpm would not go past 1500 and the light on the side of the shifter came on. Display reads ecu 128. I'm currently on the side of the road posting from my iPhone. Any help would be greatly appreciated.

    Edit: another code just popped up- Pld 084
    Edit #2: pld 084 just went away and was replaced by sld 216

    Last edited by stlwaco; 10.28.2011 at 01.35 AM.

  2. #2
    Light Load Member Sparkz's Avatar
    Member Since
    Jul 2011
    Location
    New Zealand
    Trucker?
    Trucking Industry
    Posts
    76
    Thanks
    0
    Thanked: 14 Times
    128 is engine.
    PID84 is vehicle overspeed. Flash code 72.
    SID216 ???

    What are the flash codes and which lights are they on? Red =active. Amber = historic.

  3. The Following User Says Thank You to Sparkz For This Useful Post:


  4. #3
    Light Load Member Sparkz's Avatar
    Member Since
    Jul 2011
    Location
    New Zealand
    Trucker?
    Trucking Industry
    Posts
    76
    Thanks
    0
    Thanked: 14 Times
    Just had a look in another manual. PID84 is also faulty Vehicle Speed Sensor, Code 54.
    When this code is active on a truck with Road Speed Limiting turned on, your engine revs will be limited to what they would be in top gear at the speed limit. This is to prevent drivers disconnecting the VSS to go faster than the RSL.

    SID216 is code 55, missing J1939 data from another ECM. Is the gearbox a straight manual or has it got electronics?

  5. The Following User Says Thank You to Sparkz For This Useful Post:


  6. #4
    Light Load Member stlwaco's Avatar
    Member Since
    Oct 2009
    Location
    St. Louis, MO
    Trucker?
    No Answer
    Age
    28
    Posts
    276
    Thanks
    76
    Thanked: 45 Times
    Ok the speed sensor makes sense. I noticed the speedo dropping a couple times on the trip up. The trans is a lightning series 10 speed.

  7. #5
    Light Load Member stlwaco's Avatar
    Member Since
    Oct 2009
    Location
    St. Louis, MO
    Trucker?
    No Answer
    Age
    28
    Posts
    276
    Thanks
    76
    Thanked: 45 Times
    Think I traced it down to loose battery connections. Got her moved down the road to the dealer. Cleared codes and test drove. No more codes.

  8. #6
    Trucker Forum STAFF PackRatTDI's Avatar
    Member Since
    Jul 2006
    Location
    El Chuco, Tejas
    Trucker?
    5 Years
    Age
    39
    Posts
    7,598
    Thanks
    220
    Thanked: 7,060 Times
    I had the exact same problem in the 04 Columbia I drive. Since my truck isn't governed I didnt run into the RPM limit but I'd lose cruise control, no speedometer and sometimes wouldn't shift from 6th to 7th or from 9th to 10th since it has the top 2 auto shift. The lightning transmission computer had to be replaced, for some reason it was not getting the speed sensor reading consistently. Later on I lost all power and it was due to a defective battery cable connected to the starter. I have a feeling the voltage fluctuation probably fried the computer. Since the battery cable was fixed I've had none of the electrical gremlins that had popped up from time to time.

    If the problem comes back it may be the transmission computer is defective. The one in my truck was a recent replacement that was swapped under warranty.

  9. The Following User Says Thank You to PackRatTDI For This Useful Post:


  10. #7
    Trucker Forum STAFF PackRatTDI's Avatar
    Member Since
    Jul 2006
    Location
    El Chuco, Tejas
    Trucker?
    5 Years
    Age
    39
    Posts
    7,598
    Thanks
    220
    Thanked: 7,060 Times
    FWIW, when my problem came up I got ECU 128 and ECU 130, which means an engine AND transmission code.

  11. The Following User Says Thank You to PackRatTDI For This Useful Post:


  12. #8
    Road Train Member Pablo-UA's Avatar
    Member Since
    Oct 2010
    Location
    Borispol, Ukraine
    Trucker?
    Trucking Industry
    Posts
    6,593
    Thanks
    24
    Thanked: 1,153 Times
    Plz full codes MID 128 SID PID PSID PPID FMI

  13. The Following User Says Thank You to Pablo-UA For This Useful Post:


  14. #9
    Light Load Member stlwaco's Avatar
    Member Since
    Oct 2009
    Location
    St. Louis, MO
    Trucker?
    No Answer
    Age
    28
    Posts
    276
    Thanks
    76
    Thanked: 45 Times
    well it didnt last long. problems came back with a solid service light on the shifter. Got it towed in to the dealer. Lightning ECU is getting replaced.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •