Trucking Jobs New Driver Jobs Flatbed Jobs Tanker Jobs Refrigerated Jobs Auto Hauler Jobs
Results 1 to 2 of 2
  1. #1
    Bobtail Member
    Member Since
    Jul 2012
    Trucker?
    25 Years
    Posts
    1
    Thanks
    0
    Thanked: 0 Times

    smartshift codes and problem

    2006 freightliner columbia with a merritor smart shift. The codes that come up are 3D-E7 and SM. Have been too 3 separate shops and none can find the problem. They say the codes are read but are not active. The last shop ohmed all of the shift motors and said the are within specs. These codes come up and the truck may run from 1 to 5 days and then the tranmsmission will not shift. So I am stuck in whatever gear this happens at. Let the truck set for an hour or so and the codes are still there but am able to shift gears. So far this happens only when loaded? Put in a double voltage regulator and a new shift paddlem to no avail. Any ideas or suggestions? Thank you


  2. #2
    Bobtail Member
    Member Since
    Aug 2011
    Trucker?
    1 Year
    Posts
    14
    Thanks
    15
    Thanked: 3 Times
    Did the shops hook up the trans to a computer or did they just pull the codes and OHM stuff out, here is a link so you can ck the codes for your self.
    http://www.zf.com/na/content/media/u...ss8/mm0150.pdf
    http://www.gtdev.com/products/smartshifttrouble.pdf

    when was the last time the trans shift fork was serviced and when was the last time the shift actuator was checked for air leaks. I know the book says the clutch says it never needs service but the fork build up with dust and can casue some issues. I had one issue where a battery was going bad and by dumb luck the tech found it that an a dirty connector. good luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •