pete 379 cruise control

Discussion in 'Peterbilt Forum' started by sidekick72, Feb 2, 2011.

  1. sidekick72

    sidekick72 Bobtail Member

    Messages:
    15
    Thanks Received:
    2
    Joined:
    Feb 17, 2010
    I have a 2001 pete379 that the cruise doesn't kick out when I press the brake pedal. I was told that it had a sending unit in behind the dash on the right side of the steering column but I can't seem to find it.The only sending unit I find in this area is an oil pressure snesor that is tied into the cool down timer which is to shut down the engine in case of oil pressure drop while left unattended with the timer on.Anyone know of a better place to look for this sending unit?
     
  2. country29

    country29 Medium Load Member

    Messages:
    513
    Thanks Received:
    135
    Joined:
    Feb 27, 2010
    Location:
    Arkansas
    pull the kick panel out from below the steering column, and next to the firewall there will be an aluminum block that should have a couple sensors on it, 1 will be for brake lights the other if im not mistaken will be for cruise, but I dont remember which is which. hope this helps.
     
    sidekick72 Thanks this.
  3. Rig Wrench

    Rig Wrench Medium Load Member

    Messages:
    390
    Thanks Received:
    57
    Joined:
    Dec 24, 2010
    Location:
    northeast
    I dont think its really a sending unit, its a relay, should be the same as the ones in your fuse panel if i recall corectlly. Should be all the way on the left side of the dash behind panel, possibly behind the speedo and tach, as long as no one has moved it from the factory location. you may have to dig a little in the dash as paccar's wiring has much to be desired and it may be buried pretty deep.
    if not you may also check that all your brake switches in the floor are working so that the brake signal is getting sent. They go bad quite often also
     
    Last edited: Feb 3, 2011
    sidekick72 Thanks this.
  4. bubbanbrenda

    bubbanbrenda Road Train Member

    Messages:
    1,348
    Thanks Received:
    600
    Joined:
    Feb 27, 2011
    Location:
    Middletown,Oh.
    I'm guessin you don't have brake lites either, All of the electric goes for the brake lites and turn signals and such go thru the signal stat (turn signal box on side of steering column) The bad part is they are truck specific and not just any one will do,the one for my 2000 379 was $79.99 the one for my brothers 01 379 was $59.99 same dealer,same counter person,same time of day. Just depends on how your truck is optioned
     
  5. Pumpkin Oval Head

    Pumpkin Oval Head Heavy Load Member

    Messages:
    779
    Thanks Received:
    240
    Joined:
    Jun 24, 2010
    Location:
    Martin, TN
    I had this problem, and it was a fuse in the fuse box that was the problem....you may want to eliminate that as the culprit first. :biggrin_25524: