12.7 Detroit backfires and throws fireballs

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by Flipp, Apr 11, 2020.

  1. Flipp

    Flipp Bobtail Member

    13
    15
    Apr 16, 2019
    0


    Watch the video and let me know what you think please

    Truck info, 2006 FL classic glider, ddec4 12.7,
    It's been doing this for about 3 years now, started sometime after having Freightliner do the bull gear. Engine has had a complete inframe including a reman head, injectors, pistons, liners, bearings, oil pump. Had no effect on the problem what so ever. Turbo was replaced with the bw171702 sometime near when this started, don't remember if before or after, also don't know if that could do something like this. Jake's have been rebuilt, no effect. Cam timing was off 1 tooth, had that addressed, checked gears in the front cover, injectors pass the cutout test, no codes. I'm sure there's more I've tried that I'm forgetting, but I am completely out of ideas, any help would be very appreciated
     
    jamespmack Thanks this.
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Snow Hater

    Snow Hater Medium Load Member

    357
    709
    Dec 26, 2019
    0
    I'm not a diesel mechanic but I did sleep well last night. Timing is the first place I'd look since something was supposedly broken and repaired that affects this.
     
    jamespmack Thanks this.
  4. Rideandrepair

    Rideandrepair Road Train Member

    13,853
    46,141
    Aug 8, 2015
    0
    My neighbor had timing off 1 tooth, after getting bull gear done, another mechanic caught it, also had to change head, because of bent valves.
     
    Hulld and jamespmack Thank this.
  5. AModelCat

    AModelCat Road Train Member

    24,062
    119,856
    Jul 7, 2015
    Canuckistan
    0
    Does she smoke any colour other than black when at low idle, high idle, accelerating, decelerating, under load etc?

    How well does it start in warm temperatures and in cold temperatures?

    Sounds like you've done some work on it. Are you 100% certain the cam is timed properly? Almost sounds like injection timing is off. Not sure where the S60 gets its position signal from but is it possible the component that the EPS reads from was installed out of time?

    @swaan @benjamin260_6
     
  6. Flipp

    Flipp Bobtail Member

    13
    15
    Apr 16, 2019
    0
    A few things I should add, the truck runs perfect 90% of the time, not a single hiccup. When I had the cam timing fixed it had no effect at all, doesn't run any better or worse than before. Same with the popping and backfiring. When it starts acting up is when I hit the throttle slow after coasting, only over about 1500 rpm. And never at high
     
  7. Flipp

    Flipp Bobtail Member

    13
    15
    Apr 16, 2019
    0
    When it pops a little it smokes grey, sometimes I can makeit do it at idle, that's really where I can tell it's puffing grey smoke and also I don't know what this means but it smells really wired when it does it I can't really identify the smell confidentiality, doesn't really smell like burning oil or anything. To be clear tho it is not very common that it has any hiccups at idle, but occasionally if I rev it while parked it will pop and crackle at about 1500, but if I floor it it will go to redline without popping.
    It starts pretty smooth no matter the temp.
     
  8. baha

    baha Road Train Member

    3,939
    2,527
    Jul 25, 2013
    ga
    0
    A Bad Head/Gasket will make those 12/7 eng. back fire like a mama jammer
     
    speedyk and Rideandrepair Thank this.
  9. 062

    062 Road Train Member

    5,145
    12,881
    Oct 20, 2013
    0
    Do you know if it was a Fitzgerald built motor?
    A local had a fitz glider that would score #5 in 60-75k miles like clockwork. They finally put another motor in because they couldn’t figure out the problem.
     
    Rideandrepair Thanks this.
  10. Rideandrepair

    Rideandrepair Road Train Member

    13,853
    46,141
    Aug 8, 2015
    0
    Mine is sputtering,sometimes after it’s been idling. Same rpms, around 1550-1600, I’ve noticed if I hold it there it will keep sputtering. Once I rev it up good, it catches. Definitely gets worse when fuel filters are plugging up. And does it a bit after changed. I’m sure it’s sucking air between tank and fuel pump. It blows a bunch of white/ grey smoke when it does it.Otherwise It runs better than ever, fresh overhaul, everything’s new. Injector harnesses and fuel shut off valves are a common problem on Freightliner’s/ Detroits. I’m going to eliminate the shut offs, and change injector harness if needed, if not eventually.
     
  11. Flipp

    Flipp Bobtail Member

    13
    15
    Apr 16, 2019
    0
    I would think if it were the head or gasket it would have been resolved with the inframe.

    The the truck was originally built as a glider by a private shop with a Detroit reman. Made it over a million miles with no issues.
     
    Rideandrepair Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted