12.7 Detroit backfires and throws fireballs

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by Flipp, Apr 11, 2020.

  1. DetroitDudeBro

    DetroitDudeBro Bobtail Member

    9
    9
    Apr 29, 2021
    0
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. DetroitDudeBro

    DetroitDudeBro Bobtail Member

    9
    9
    Apr 29, 2021
    0
    MINE HAS DONE THIS CRAP TOO!

    Bought a diagnostic laptop and have been watching the timing BOI (beginning of injection) closely with Detroit DiagnosticLink. Had to activate the boi setting in DCT. I noticed my timing would at times drop below 0 BTDC (before top dead center) seen it at low as -3 and timing at that point reliability caused it to pop, backfire and smoke grey/white until advanced timing would return I guess anything below 0 would add fuel ATDC (after top dead center)?!? My problem seems to only occur when the engine is around 1500-1700rpm and feathering the pedal after coasting, or pushing hard suddenly while in town at that same RPM range. So far... the problem has been corrected by advancing the boi minimum allowance so it doesn't drop below 0. I'm sure there's much more that needs to be done with my calibration by a good tuner. However I can't seem to find anyone that knows about this issue or more likely scenario.. doesn't wanna divulge how fine tuning is done. Most guys only wanna add fuel and change the injector trims. Don't get me wrong, that's plenty effective and does add power but does nothing to address issues like this. Any other thoughts on what could be causing an issue like this? Timing seems to be key
     
    Last edited: Apr 29, 2021
    Reason for edit: Typo
    Rideandrepair Thanks this.
  4. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  5. Brettj3876

    Brettj3876 Road Train Member

    9,809
    45,170
    Nov 18, 2014
    Stuck in Limbo
    0
    @benjamin260_6 wait for him to come along.

    Otherwise stock build? Has been rebuilt recently? Low nox file? Had the same happen to an E-7 mack. Dropping from 16.9 comp pistons to 15.3 it would spit and sputter under no/light load conditions and throw white/grey unburnt fuel. Would clear up as soon as you stepped on it and put some load on the engine. Timing was a bit too far retarded. Advancing it a few deg helped it.

    May or may not be your issue
     
    Rideandrepair and DetroitDudeBro Thank this.
  6. DetroitDudeBro

    DetroitDudeBro Bobtail Member

    9
    9
    Apr 29, 2021
    0

    Pretty sure mine was rebuilt with the OE low NOX parts and had the low NOX file until recently.

    My truck would smoke heavily on a cool start and was absolute INSANITY with cold starts. I was always expecting someone to call the FD about a truck fire. Have that issue mostly in check. Timing on mine was definitely too far retarded. Alongside with overfueling it had some eye burning stank ### fumes at idle.
     
    Rideandrepair Thanks this.
  7. Torquemonkey321

    Torquemonkey321 Bobtail Member

    1
    1
    Apr 29, 2021
    0
    Hello sir what parameter exactly did you change? I have looked through the different boi parameters and my min boi is at 0, the filter construct boi min is at -10.
     
    Rideandrepair Thanks this.
  8. DetroitDudeBro

    DetroitDudeBro Bobtail Member

    9
    9
    Apr 29, 2021
    0
    Filtq_min_boi
     
  9. benjamin260_6

    benjamin260_6 Medium Load Member

    413
    450
    Aug 8, 2012
    Ontario, Canada
    0
    This definitely sounds like retarded timing. If the bullgear was changed at a detroit shop then there's a definite possibility that they updated the ECM at the same time and now you have one of those wonderful low-nox calibrations. The TK60s and PK60s reacted the worst to those updates and are the most likely to get the low-nox update so if you have one of those, that's where I'd be looking. It's a pretty simple fix but it has to be done aftermarket, not at a detroit shop
     
    Rideandrepair and DetroitDudeBro Thank this.
  10. wilco379

    wilco379 Bobtail Member

    22
    11
    Oct 2, 2021
    0
    I have a 98 pete 379 with a 12.7 Detroit in it, been having this problem for months now. the problem is intermittent some days its great some days it acts up, right as you start rolling in the the throttle at lower speed and low rpm "1500 to 1600" it will start to pop and stumble and blow whiter grey smoke out the stacks it smells of raw fuel. does not do it at high way speeds. so far i have replaced the suction lines, filter head, new filter, new fuel pump, new map sensor, check check valve on return line and 0.80 restricted 90 on return. currently pulled all injectors out and re o-ringing them and putting new cups in, injectors have about 50,000 on them along with the entire motor, any help would be appreciated.
     
    DetroitDudeBro and Rideandrepair Thank this.
  11. Rideandrepair

    Rideandrepair Road Train Member

    13,853
    46,138
    Aug 8, 2015
    0
    Exactly what mine does. Didn’t start doing it till after an inframe. I’ve replaced all the same stuff over past 3-5 yrs. Next move was to pull injectors, thinking I have a bad one. Only have 74k on the inframe. Thought it might be a bad injector seating in the cup. New head, new injectors. We didn’t install any crush rings, since they shouldn’t be needed. Only if cups are damaged. Then it’s not ideal anyway. I thought it might be the accelerator module. But it does it on cruise too. Somewhere there’s a bad signal maybe. Going to replace injector harness, when I run the overhead soon. Eventually the Engine harness also. Also suspect possible oil in either of the harness plugs on ecm. Please let me know if you figure this out. I’ll do the same.
     
    wilco379 and DetroitDudeBro Thank this.
  12. Joyce's Volvo

    Joyce's Volvo Light Load Member

    70
    79
    Jun 28, 2016
    0
    Had similar problem, popping with smoke , the jake was coming on when giving fuel. Sometimes partial jake, sometimes full, makes heck of a racket.
     
    Rideandrepair and Oxbow Thank this.
  13. Rideandrepair

    Rideandrepair Road Train Member

    13,853
    46,138
    Aug 8, 2015
    0
    What was the problem? Jakes not adjusted correctly? Something else?
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted