14 KW T800 passenger taillight is brighter when running lights on.

Discussion in 'Kenworth Forum' started by Rsimplehomes, Oct 30, 2023.

  1. Rsimplehomes

    Rsimplehomes Bobtail Member

    2
    0
    Oct 30, 2023
    0
    My 2014 KW T800 passenger side taillight is brighter (like the break is being pressed bright or the turn signal is on) than the driver's side taillight. I just purchased new LED taillights and I thought got a bad light, but when I switched them out passenger to driver/driver to passenger, the same thing happens. All wiring is secure and connections are good. Thx
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Rsimplehomes

    Rsimplehomes Bobtail Member

    2
    0
    Oct 30, 2023
    0
    All the wiring at the taillights is secure. I had another mechanic say it could be the chassis node? Is this the same part as the electronic chassis control module?
     
  4. kwcam

    kwcam Light Load Member

    192
    145
    Dec 29, 2012
    at the shop
    0
    Are you sure the wiring pigtail was not wired up correct? with only four ways on are they same brightness?
     
  5. xsetra

    xsetra Road Train Member

    4,898
    6,518
    Aug 21, 2011
    0
    Check your wire connections and ground posts.
    Even with proper power feed, if your ground is bad the light won't illuminate bright.
    You may have a corroded wire inside the insulation you can't see.
    Good luck.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted