1999 Int. 4700 T444e no power under 50 mph

Discussion in 'International Forum' started by Gradyy, Aug 30, 2022.

  1. Gradyy

    Gradyy Bobtail Member

    5
    0
    Aug 30, 2022
    0
    Former Emergency Management command center. Always maintained but sat for 2 years. 275,000 miles Starts right up and runs fine except that any uphill grade from a stop or slow roll is painfully slow and labored. Once it hits 50 +/- it will scream up hills. Fuel filter and screen are new. Oil is clean. Any ideas?
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. circle h

    circle h Light Load Member

    186
    279
    Oct 22, 2020
    0
    Check the charge air cooler, pipes and hoses for leaks. Check the up pipes, back of the heads to turbo for leaks. I have a 4700 with a 444 and an allison. It's never had any power to speak of. It's still kicking at 386000 miles though.
     
    Gradyy Thanks this.
  4. Gradyy

    Gradyy Bobtail Member

    5
    0
    Aug 30, 2022
    0
    Thanks. I checked the main pipes and hoses and they are all in good shape. I'll check the ones on the back of the heads. What's the best way to check the charge air cooler for leaks?
    It does have the Allison trans - the only one I've ever seen with "Park" - that when selected automatically applies the air brake.
    I also have a 1997 4700 T444e with a manual trans that doesn't suffer from excessive power but never makes me think something is wrong.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted