2001 T800 turn signal wire diagram?

Discussion in 'Kenworth Forum' started by Green461, Jul 18, 2020.

  1. Green461

    Green461 Light Load Member

    70
    31
    Mar 22, 2019
    Southern WI
    0
    Anyone have a diagram for this? Both turn signals slowly started going out over a day, they'd blink once every 3 seconds, real slow, then today nothing.... but hazards work. I replaced the flasher and same thing. Flasher functions normal because the hazards use it as well and they work. What would cause them to slowly stop working. If i switch the signal on, right or left, the light might come on for a split second and then nothing.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. AModelCat

    AModelCat Road Train Member

    17,559
    75,395
    Jul 7, 2015
    Canuckistan
    0
    Could be worn contacts in the signal stat. Have you tried jiggling the arm to see if it makes a difference?

    I believe the signal stat will supply constant power to the flasher and the flasher opens/closes the circuit. If you have a power supply issue or a worn switch you'd be interrupting the constant power to the flasher and it could affect its normal operation.

    (The above is an educated guess, been about a decade since I played with trucks on a regular basis)
     
  4. FLHT

    FLHT Light Load Member

    277
    186
    Aug 2, 2014
    0
    Bad ground
    Worn out signal stat
     
  5. Green461

    Green461 Light Load Member

    70
    31
    Mar 22, 2019
    Southern WI
    0
    Anyone know where i can find a pinout for the connector going to the signal switch? I got the switch out and would like to test the terminals with ohm meter...
     
    Last edited: Jul 19, 2020
  6. Green461

    Green461 Light Load Member

    70
    31
    Mar 22, 2019
    Southern WI
    0
    New signal switch... when you turn them on it gives one blink then nothing. Be so awesome if there was a wire diagram.
     
  7. Green461

    Green461 Light Load Member

    70
    31
    Mar 22, 2019
    Southern WI
    0
    #### dealer wont help either... told me to google it. lol. Been looking through google schematics for hours... nothing.
     
  8. Green461

    Green461 Light Load Member

    70
    31
    Mar 22, 2019
    Southern WI
    0
    Called different dealer and they emailed me schematics. So... at the flasher there is 12.6v going in, 12.6v going out, and when the signal is on only 4.6v coming out and flasher would not flash., I tried 6 different flashers, all same results varying 4.6-8v the lights would not blink. 3 months ago i installed LED light bulbs in my fender mount signals, so that and all my lights in back are LED, no incandescent bulbs at all. The front i got the CAN BUS (resistor built in) bulbs so they flash at a normal rate... No issues at all, super bright and everything normal. Swapped an old bulb back into one of them and the flasher started working perfect. I even had some new LED CAN BUS bulbs and wouldnt work at all. But swapped the old bulbs back into both sides and all works now. Weirdest #### ever.
     
  9. FLHT

    FLHT Light Load Member

    277
    186
    Aug 2, 2014
    0
    LEDs do not draw enough voltage to make the dam things work. I have heard of a few with the same problem. They wired in a few bulbs to make it work.
     
  10. Green461

    Green461 Light Load Member

    70
    31
    Mar 22, 2019
    Southern WI
    0
    The CANBUS ones are supposed to, very odd it worked for 3 months, then faded slowly. Attached schematic if anyone else stumbles on this threat with similar issues.
     

    Attached Files:

    QUALITYTRUCK Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted