2007 dt466 4300 code 543 SPN 155 FMI 7 no start

Discussion in 'International Forum' started by BreakOnThrough, Jul 28, 2020.

  1. BreakOnThrough

    BreakOnThrough Bobtail Member

    14
    9
    May 31, 2020
    0
    Good evening. 175k dt466. Replaced 6 injectors, icp sensor, valve cover gasket, high pressure oil rail seals, lift pump ( leaking into oil ) , hand primer, Egr cooler , crankcase canister on side of valve cover, service, all filters about 3 weeks ago for 3 injector codes, low fuel pressure code, oil dilution and a fair oil leak from swollen /split crankcase breather canister. All from an authorized international parts dealer. Ran great. Best it’s ran in the 2 plus years it’s been under my Watch.
    Well, I figured wrong when I thought this truck would be dependable. One day last week it wouldn’t restart Hot. Pulled SPN 254 FMI 8 “ unexpected reset fault “ Active . Ok. No hpop issues, ipr 20% cranking, good pressure. ( this is from memory, but I recall everything looking good ) Here’s where that oil leak comes in from can on rear of valve cover. The entire rear ECM/IDM harness is just soaked with oil. At the time , I had doghouse out, and pressure washed it best I could. Remember, this is 2/3 weeks ago. It ran great after washing for a few hundred miles I’m guessing.
    So, back to last week. I have it idling, reach through to wiggle harness at IDM area from wheel well and truck stalls. I think , great!! Found a problem. Never could restart after it stalled with my harness tug at IDM. It wasn’t even a tug, more like a wiggle. Pull doghouse back out. Cleaned every connection at batteries. Positive and negative. New fuse holders even though I couldn’t find any problems. Re did the connectors that were cut out previously on clean power harness and cleaned contacts at starter. Positive/negative. Cleaned grounds at block near starter. Voltage drop tested good. Cleaned positive/negative contacts at firewall above relay box. Can light a sealed beam on IDM relay pins 30/87. ECM is powered up at X4 pins 1/2. X3 pin 3. ECM relay control pin 5 at X3 is solid. IDM has Vign/B+ at pin 7. Via pin 9 in 12 pin connector 6011. Can load pins 1&9 at 12 pin connector 6011 and bulb is bright. Pin 1 leads to IDM grounds.

    I’ve been all over this truck. Probably 6 hours just chasing pins. What I find as an issue is 1.47 volts at pins 12 & 6 at 12 pin connector. Pin 12 leads to IDM power supplies at pins 4,23,24,25. Pin 6 leads to IDM logic power at IDM. **** is the IDM logic fuse the 10 amp in battery box? My schematics show a 10 amp fuse I can’t really say I have found. I’ve read it can be over valve cover on buses, ( not a school bus ) but I cannot locate it! Also, it seems IDM pin 27 isn’t providing a ground to IDM Relay? If I add a ground relay clicks, but no change?
    This truck is eating my lunch. I’m on and off because as luck would have it, all hell has broken loose these last couple weeks. Lots of equipment breaking.
    I found that my CAN 2 is live even plugged into IDM. No EGR CAN codes. 4 volts on multi meter PINS 30/31. No scope available at the moment. I have NEDS And JMaxx1708. Didn’t look to see if CAN2 has live data graphing. I figure if CAN2 was down I would have 368 codes for EGR ? It is a communication code that’s now active. The reset code isn’t coming up, just the IDM/ECM communication is active. I saw a resistance test on Mitchell that states that I should have less 5 ohms between IDM case and ground. It’s open or out of scale. Also, resistance from IDM X3 pin 32 to ground less than 5 ohms. It’s open or out of scale. Says replace IDM. My gut says IDM is bad, but it wasn’t too long ago I was burned on a WABCO brake module. 1600 sitting on a shelf. Sorry for the LOOONG post, but this is necessary information for my problem. Hoping a more experienced International Tech, or someone with some wisdom to pass on can help. Thanks.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. BreakOnThrough

    BreakOnThrough Bobtail Member

    14
    9
    May 31, 2020
    0
    It might be 2 volts on CAN2 pins 30/31 at connector X3 at IDM. IM USING A MULTI METER, which isn’t ideal. I know. I think it might be averaging the reading. Not certain, I can say it is not shorted to ground or B+. I wonder if IDM pin 27 were grounding IDM relay, if puns 4,23,24,25 would come alive? That’s kind of where I’m at. Just not enough experience with the dt466 yet.
     
  4. Heavyd

    Heavyd Road Train Member

    7,017
    5,064
    Feb 4, 2009
    0
    Ok, when the IDM goes bad, you usually get the unexpected reset fault along with 525 code for internal IDM fault. So if you only have the unexpected reset, (626), then I would focus on powers and grounds. These are tricky to troubleshoot because both the ecm and idm turn themselves on through supplying a ground to trigger the ecm and idm relays. So yes, the idm supplies itself a ground at x3 pin 27 which triggers the idm relay to send power to 8, 4, 23, 24 and 25(all x3). So when you have this disconnected, you just have to jump pin 27 to ground to get the relay to trigger.
    ECM needs ecm connector x3 pin 5 grounded to trigger the ecm relay to send power to ecm connector x4 pins 1 and 2. Start with that and let me know.
     
    QUALITYTRUCK and BreakOnThrough Thank this.
  5. BreakOnThrough

    BreakOnThrough Bobtail Member

    14
    9
    May 31, 2020
    0
    Ok, will do. Appreciate it. It does have the code 543 SPN 155 FMI 7 active currently. That’s the ECM/IDM communication fault code . Hard code, as it reappears as soon as I clear it. AlwYs active. Will jump pin 27 in the morning, see if the IDM power supplies show up. It does have power at ECM pins 1&2 on X4 and pin 3 on X3. Also the ECM is properly grounding the ECM relay at X3, pin 5. I hadn’t thought to jump ground at pin 27 at IDM. THANKS!
     
  6. BreakOnThrough

    BreakOnThrough Bobtail Member

    14
    9
    May 31, 2020
    0
    So , if I unplug connector X3 at IDM, and jump pin 27 relay clicks and I have power at all the pins I need to have power at. Pins 4,8, 23,24,25 come alive.
    I can load each pin with a sealed beam headlight and the light is bright each pin.
    So I reason IDM is no good? It’s no longer grounding IDM relay.
     
  7. Heavyd

    Heavyd Road Train Member

    7,017
    5,064
    Feb 4, 2009
    0
    Load test your grounds too. Also X3, pins 1, 2, 3, 22 and 26. As for the 543, we don't get into data streams, just the actual continuity testing. You are right, the CAN 2 is only for IDM, EGR and ECM communication. The lack of code 368 just means the datalink is good between the ECM and EGR. I would disconnect the EGR module and just do a basic continuity test between the IDM x3 pin 30 and 31 to the ECM connector X2 pins 6 and 13. If 30 to 6 and 31 to 13 are both good and no shorts to grounds or other circuits, and you have powers and grounds are good too, plus you checked for good ignition power at the IDM too, then I would say you have a failed IDM.
     
    BreakOnThrough Thanks this.
  8. BreakOnThrough

    BreakOnThrough Bobtail Member

    14
    9
    May 31, 2020
    0
    Will update when I have it fixed. Thanks for the advice.
     
    Heavyd Thanks this.
  9. BreakOnThrough

    BreakOnThrough Bobtail Member

    14
    9
    May 31, 2020
    0
    Well Heavy, I loaded all the grounds AT IDM and have good continuity on the CAN2 from IDM to ECM. Loaded all the power supplies when I ground pin 27 at IDM, they’re good. I also have the Vign from ignition switch at IDM. It’s time to buy an IDM. My parts guy said I can take the ECM/IDM to International and they can set up new IDM. That way I don’t have to tow truck etc. Will update results when I have IDM installed
     
    Heavyd Thanks this.
  10. BreakOnThrough

    BreakOnThrough Bobtail Member

    14
    9
    May 31, 2020
    0
    Installed IDM around 3:30 this afternoon. Truck fired right up. Thanks for the advice Heavyd. I couldn’t afford to be wrong after a fiasco I had with a Wabco hydraulic brake system I misdiagnosed a few months ago.
    I load tested every single circuit From the ignition switch to the relays.
     
    Heavyd Thanks this.
  11. Heavyd

    Heavyd Road Train Member

    7,017
    5,064
    Feb 4, 2009
    0
    Yes, I know the sinking feeling, been there! Glad it worked out! Miller time!
     
    BreakOnThrough Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted