2007 peterbilt 387 Gauges not working

Discussion in 'Trucking Electronics, Gadgets and Software Forum' started by ZELLA6711, Sep 8, 2022.

  1. ZELLA6711

    ZELLA6711 Bobtail Member

    1
    0
    Sep 8, 2022
    0
    All my gauges quit working. 2007 peterbilt 387. Electronic log won’t flip over to drive mode. If I unplug the speedometer everything goes back to normal except the speedometer and the ELD. Some friends say replace the speedometer head. I don’t know
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. aussiejosh

    aussiejosh Road Train Member

    4,349
    4,496
    Aug 28, 2009
    Airlie Beach QLd
    0
    If all your gauges have bit the dust its more than likely a fuse has blown.
     
  4. Six9GS

    Six9GS Road Train Member

    1,474
    3,675
    Dec 3, 2012
    Yuma, AZ
    0
    We don't need no stickin' gauges! 20220908_172101.jpg
     
  5. Old Man

    Old Man Road Train Member

    4,527
    13,090
    Apr 3, 2009
    Oklahoma City, OK
    0
    Not sure on that model but a 379 has a relay behind the left dash panel, acothere are two, sit back to back. The smaller one closes the big one and it powers the gauges and other things, when going bad it doesn’t close completely and crazy things happen.
     
  6. Ridgeline

    Ridgeline Road Train Member

    18,795
    87,179
    Dec 18, 2011
    Michigan
    0
    You have a problem with the communications bus which runs the eld, speedometer and most of the gauges, if you unplug the speedometer and everything works than more likely than not it is a defective speedometer. You can get it repaired or buy another one - used are out there.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted