2014 Volvo VNL D13 long starts

Discussion in 'Volvo Forum' started by cornhusker17, May 22, 2024.

  1. cornhusker17

    cornhusker17 Bobtail Member

    2
    0
    May 22, 2024
    0
    1.1 million miles on the old girl. Was planning on using it sparingly to haul grain. Seems to be loosing prime and can take 10 seconds of cranking before it starts. Starting Fluid does seem to help, but not every time.
    I just changed the fuel filter and water separator on the Davco system with no help. Still has the same symptoms.
    I don't have a computer to check fuel pressure so when I replaced the filter I did turn it over to see how quickly the fuel came out and was shocked how little cam out of the filter housing with 3 seconds of crank time. I am suspecting the fuel pump, but once it starts it runs great. Ran it 6 hours to get it home, then 5 minutes after running it looses prime and takes forever to start again. Looking for suggestions on where to go next? Pump, relief valve, or are we suspecting an injector issue. No check engine lights even after long crank times. Seems to run good once its going.
    Thanks!
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. loudtom

    loudtom Road Train Member

    1,664
    2,668
    Aug 26, 2016
    0
    Fuel filter housing can also cause that problem. Mine had those symptoms, but I knew it was the housing because it would leak when I would go to prime it by hand.
     
  4. cornhusker17

    cornhusker17 Bobtail Member

    2
    0
    May 22, 2024
    0
    Is there replaceable O rings or did you replace the entire housing?
     
  5. loudtom

    loudtom Road Train Member

    1,664
    2,668
    Aug 26, 2016
    0
    I replaced the housing.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.