60 series 12.7

Discussion in 'Trucks [ Eighteen Wheelers ]' started by wtwfarms2018, Feb 21, 2024.

  1. wtwfarms2018

    wtwfarms2018 Bobtail Member

    3
    3
    Feb 21, 2024
    0
    I have a 12.7 ddec 4 that I replaced the head on. Truck was running before I changed it. Put new injectors and new cam in it. Set cam gear back in same position as it came out. The ECM is not sending power to injectors to fire. Changed injector harness, changed sensor harness, replaced TRS & SRS sensors. Sent ECM out and had it gone through. Its showing oil pressure code (inactive). I changed TRS sensor again and for some reason got rid of oil pressure code but have a engine position sensor code. Put old sensor back in and oil press code comes back and no engine position sensor code. I can't figure out why this thing wont run. Checked all power and grounds, and ohm'd new sensor harness
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Big Road Skateboard

    Big Road Skateboard Road Train Member

    4,356
    20,673
    May 2, 2021
    0
    You are able to hook a laptop to it? Verify that after cranking it shows SRS Received as Yes.

    Did you run the overhead, and did you turn the engine over when the cam gear was out?
     
    Rideandrepair Thanks this.
  4. wtwfarms2018

    wtwfarms2018 Bobtail Member

    3
    3
    Feb 21, 2024
    0
    So I did forget to mention, hooked DDL up and the ecm isnt reading rpms. ran overhead, engine did not move before re install
     
    Rideandrepair Thanks this.
  5. DDguy

    DDguy Light Load Member

    146
    93
    Apr 21, 2020
    Ont. Canada
    0
    So this engine will not fire unless it sees both TRS SRS once its running if it looses one it normally stays running untill you shut it off
    Have you checked the Bull gear for play ?
     
    Rideandrepair Thanks this.
  6. Rideandrepair

    Rideandrepair Road Train Member

    16,514
    53,919
    Aug 8, 2015
    0
    Have you primed and pressurized the fuel tanks? Won’t do it simply by cranking.
     
  7. 062

    062 Road Train Member

    5,847
    31,634
    Oct 20, 2013
    0
    I know next to nothing about a Detroit, but have you checked fuel pressure while cranking?
    I know some engines will not fire the injectors until a minimum pressure is seen.
     
    Vampire and Rideandrepair Thank this.
  8. DDguy

    DDguy Light Load Member

    146
    93
    Apr 21, 2020
    Ont. Canada
    0
    This is not the Case on detroits but yes there needs to build a few psi in the head for the injector to deliver fuel even the the ecm opens injector
     
    Vampire and Rideandrepair Thank this.
  9. little cat 500

    little cat 500 Road Train Member

    1,950
    1,004
    Jan 17, 2010
    Abbottstown PA
    0
    hit it with a shot of starting juice takes awhile sometimes to get the air out of the head!
     
    Rideandrepair Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.