Bad alternator but its new ?

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by Roman78, Aug 14, 2022.

  1. Roman78

    Roman78 Light Load Member

    68
    26
    May 20, 2021
    0
    I have cummin isx i have batteries icon on dashboard. I changed batteries same problem my powerdrive 3000 kw innovator can only run a laptop lol. If i turn on the printer for example it would restart and go crazy it would run the printer but every time i print a page inventor restarrt it self. I run a test using the power drive app. Batteries result came good. But alternator result came bad. So i went and bought me new alternator after 2 hours under the sun at the truck stop i managed to install the new alternator. Installed the belt and now its doing the same thing. Poor power with red battery icon on dashboard battery . Oh
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. buddyd157

    buddyd157 Road Train Member

    12,318
    30,236
    May 25, 2017
    under a shade tree
    0
    i'd start by making sure ALL cable connections at the batteries are clean, and tight. then i'd check all the ground connections for clean and tight fit as well.

    you have to actually remove the cables, one by one, clean them by using a battery terminal cleaning wire brush, and reinstall. wiping the top clean is NOT a clean connection.

    it "does happen" that a new or rebuilt component can be bad out of the box.
     
    Diesel Dave and rollin coal Thank this.
  4. Ridgeline

    Ridgeline Road Train Member

    18,634
    85,427
    Dec 18, 2011
    Michigan
    0
    First before you do anything, get a good inverter, a pure sine wave inverter, and pitch the chinese junk one.

    AIMS is a good inverter.
     
    GYPSY65 Thanks this.
  5. GYPSY65

    GYPSY65 Road Train Member

    1,631
    4,128
    Nov 16, 2012
    SW FLA
    0
    New part does not mean the same as it did when we were kids
    Many new parts are just as bad as the one coming off the truck but an alternator should be able to be tested off the rig
     
    W923 Thanks this.
  6. Roman78

    Roman78 Light Load Member

    68
    26
    May 20, 2021
    0
    Its new and shiny. Tested at 14. But still not charging the batteries. Conctions r clean n shiny as well. Battery icon still on dashboard n inventor is going crazy
     
  7. buddyd157

    buddyd157 Road Train Member

    12,318
    30,236
    May 25, 2017
    under a shade tree
    0
    may be a bad wire behind the alternator, the red one. sometimes it gets corroded under the crimped connector
     
    Roman78 Thanks this.
  8. Mr Bob

    Mr Bob Light Load Member

    159
    55
    Mar 17, 2015
    0
    tested on the alternator stud, the wire terminal on the stud or at the battery post ?
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted