C15 Intake valve actuator # 4 current low (93) DO I HAVE TO FIX ?

Discussion in 'Trucks [ Eighteen Wheelers ]' started by Shawn19, Jan 8, 2020.

  1. Shawn19

    Shawn19 Light Load Member

    100
    27
    Apr 20, 2019
    0
    I have a 07 freightliner c15 check engine light came on truck run good so far even with a load drop load off and had it scan ( intake valve actuator #4 current low (93) )
    Does anyone know for a fact if I can run it without fixing it or do i have to fix it ?
     

    Attached Files:

  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. tnevin225

    tnevin225 Road Train Member

    1,166
    1,590
    Jan 1, 2014
    0
    You can run with it, Your fuel mileage will suck and you turbo pressure won't go above 30lbs, but should be ok till you can get it fixed.
     
    pushbroom and QUALITYTRUCK Thank this.
  4. Majestic 670

    Majestic 670 Heavy Load Member

    908
    806
    May 10, 2016
    Landcruiser
    0
  5. Ccjohn

    Ccjohn Bobtail Member

    49
    9
    Sep 29, 2016
    0
    We have 3 C15's and a few times a year each of them throw a code for IVA. It usually goes away a day or 2 later. They run fine but like other posters have said you may get worse fuel mileage. I would run it. If the code goes away your fine. If the code stays there get it fixed but from what ive read your not going to hurt the engine.
     
  6. SAR

    SAR Road Train Member

    2,756
    36,650
    Nov 26, 2011
    ND
    0
    I would pull the valve cover and check the plastic connection going to that IVA. Most times they get brittle and loose connection. CAT does make a new updated end that you can cut out and splice the new one in.
     
    pushbroom and spsauerland Thank this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted