C15 kenworrth t600 red alarm

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by united972, Jun 15, 2021.

  1. united972

    united972 Light Load Member

    116
    13
    May 26, 2016
    0
    My temp reaches 200 uphill and the buzzer goes off but when I switch the fan from auto to Manuel on it goes away.

    what do you guys think the prob is? It only happens while going uphill and goes away when I turn the fan on Manuel but on auto fan doesn’t go on till over 200 and buzzer starts sounding.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. pavrom

    pavrom Road Train Member

    1,992
    3,786
    Apr 29, 2012
    NE illinois
    0
    ...200 is not that bad going uphill , probably computer set up this way to avoid issues with drivers who doesn't care or pay attention
     
  4. lester

    lester Road Train Member

    1,600
    3,556
    Jan 2, 2012
    NW, Iowa
    0
    A C15 won't engage fan for engine temp until 217 degrees and that setting can NOT be changed. I forget what temp sets alarms but I'm guessing around 225?

    KW may setup different than peterbilt, which I am familiar with. But there's likely two temp sensors. One for gauge and dummy light and one for ecm.
    It's pretty common for the gauge to be very inaccurate.

    As far as fixing your problem I'm not sure. Could replace the temp sensors. Or just turn the fan on manual when climbing hills.

    I watch my temp close and turn fan on at 200. I run a scangauge and can see the temp the ecm is reading. My gauge in dash is worthless
     
    BoxCarKidd Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted