cummins n14-370e cranks only

Discussion in 'Trucks [ Eighteen Wheelers ]' started by clhart426, Mar 21, 2012.

  1. clhart426

    clhart426 Bobtail Member

    43
    1
    Dec 15, 2011
    Toledo,OH
    0
    Dealing with a volvo. Turn key on, stop engine and engune fluids lights turn on, but do not shut off. Engine only cranks. Ran into this problem at the end of fall last year, but as it got colder it started to work. Now thats its hot weather again, not working. Any ideas? Maybe temp sensor or something??
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. ohio_redneck75

    ohio_redneck75 Light Load Member

    128
    51
    Sep 27, 2010
    coshocton,ohio
    0
  4. clhart426

    clhart426 Bobtail Member

    43
    1
    Dec 15, 2011
    Toledo,OH
    0
    Would a ground allow it to crank but not start? I thought if the ground was good enough for cranking itd be "good ground". Ill throw a new cable on it, it is pretty flexible and weathered. Thanks for reply!
     
  5. clhart426

    clhart426 Bobtail Member

    43
    1
    Dec 15, 2011
    Toledo,OH
    0
    Ground was not it. Pulled dog house from truck and found a "distribution" area where i think battery cables tie into ecm power? Found some corrosiin, repaired them. Still same problem. Will crank but no start. Warning lights stay in..
     
  6. Smellfunny

    Smellfunny Road Train Member

    1,100
    573
    Jan 28, 2012
    South Carolina
    0
    Do you have fire at fuel solenoid?
     
  7. blanco

    blanco Road Train Member

    1,221
    295
    Nov 20, 2009
    Gwinnett County, GA
    0
    Drainback valve ... check and make sure you have fuel in fuel filter.
     
  8. clhart426

    clhart426 Bobtail Member

    43
    1
    Dec 15, 2011
    Toledo,OH
    0
    No power at solenoid when the two lights do not shut off. Jumping power to it didnt allow ut to start either. This morning i turned the key, self check happened, lights turned off and fired right up. Very confusing, thats why i thought temp. At first
     
  9. blanco

    blanco Road Train Member

    1,221
    295
    Nov 20, 2009
    Gwinnett County, GA
    0
    Are ur tanks full or empty when it happens?
     
  10. clhart426

    clhart426 Bobtail Member

    43
    1
    Dec 15, 2011
    Toledo,OH
    0
    Theyre about 1/4 right now.
     
  11. bender

    bender Road Train Member

    2,105
    1,346
    Jul 20, 2010
    Don't Kid Yourself
    0
    Have you pulled the ECM harness plugs and checked them for moisture/corrosion/damaged connectors?
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted