Eaton Ultra Shift on Volvo, Pete, & KW

Discussion in 'Trucks [ Eighteen Wheelers ]' started by Truckin Juggalo, Jun 27, 2007.

  1. bobeagle

    bobeagle Bobtail Member

    12
    4
    Jan 15, 2011
    PLANO,TX
    0
    Thanx pro dvrs,,, I got solution from Dna.Mach here on thread....i did as he said ...Looked under truck by the differential and saw a rod hanging loose. That's the leveling rod. it was broken and a replacement done at Petro Effingham,iL shop paid $40 for rod and 1/2 hr labor..$40. Now she'z rolling like soap on ice. thanx
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. bigkev1115

    bigkev1115 Road Train Member

    2,356
    3,571
    Oct 23, 2009
    Alexandria, AL
    0
    I have 2007 780 with a D12, and autoshift. Mine would be going down the road and would go into a fault(the flashing service light, and flashing F in the gear on the DID). I solved mine by pulling over and did the following

    1. Disconnect all of the batteries and wait 10-15 mins, then reconnect them all. This resets the transmission and ECM computers.

    2. Crank the truck and go into the Diagnostics screen for the transmission ECU, and clear out all the active codes

    3. Turn the switch on real fast 2 times and let DID boot up. It should show a code 88 (which is ECM check) and then a 25 (no faults). Sometimes the 25 will follow with PD( which is Powering Down the ECM).

    4. Wait a few minutes, then turn the switch on real fast 4 times, it will show a code 88 and then all of the stored fault codes in memory. If there are none, it will show 25(no faults

    5. Turn the switch on real fast 6 times. It will show Code 88, then either a F in the dash disply will show or a 25, then N. That will clear out all of the faults in the Transmission ECM and shouldn t have anymore problems.
     
  4. Blind Driver

    Blind Driver Road Train Member

    3,080
    1,403
    Aug 7, 2006
    New Albany, IN
    0
    Has anyone had any problems with the engine depowering due to a transmission fault? The Pete dealer tells me there are no codes, engine has boost and fuel, but the engine still has no power. This started after I fired the truck up after servicing the unit (oil change, grease, adj brakes, AC service).

    It's going to Cummins next for a possible dyno pull and diagnosis, but they don't service transmissions. Everyone is blaming the Ultra Shift.
     
  5. Gould Express Llc

    Gould Express Llc Bobtail Member

    1
    0
    Sep 18, 2013
    0
    Go and get your tranny check, could b the gears grinding. I had the same problem and da tranny went out
     
  6. eastco

    eastco Bobtail Member

    16
    1
    Mar 20, 2010
    lake city fl
    0
    I just want to do I put this out there eaton has a extended warranty available for those transmissions for 1 year or 2 years up to a million miles there are
    different variations available and I purchased one for my new truck for$750 for the one year and up to 1,000,000 mile warranty it supossed to cover electronics and the x y shifter i also had to do a service on a transmission and they installed latest software I n the trans you can see at roadranger.com look under extended warrantys this is my second auto truck and I did the x y on the old one twice in 350000 miles those are 1000 dollars now
     
  7. Kenworth kid

    Kenworth kid Bobtail Member

    1
    0
    Jul 30, 2015
    0
    Someone help me please my truck want go into gear it's showing code 58 and it means I have a faulty output shaft censor have anyone had this problem
     
  8. tsp1chl

    tsp1chl Bobtail Member

    8
    0
    Nov 4, 2015
    0
    Truckin Juggalo, did you get the problem resolved..I am having the same issue.

    Thanks
     
  9. zam

    zam Bobtail Member

    17
    1
    Jul 20, 2011
    0
    Well it is most likely bad X-Y shifter. Need to replace x-y shifter and wiring harness. Could cost couple grand incl labor at big shops. Not every shop knows it because it is a mechanical fault in the transmission and wont come up in the system. Not every shop is capable either. Better go to dealer.
     
  10. Just Pankey

    Just Pankey Bobtail Member

    9
    0
    Jul 18, 2016
    0
    Hey Jaggalo,

    I know you had the automatic "ultra shift" issues back in 07, but I was wondering what you end up doing to fix the shifting issues. I am having that same issue in my 07 Mack with that dang automatic Ultra shift 10. I thought it would have been a seamless transition from manuel to automatic, but boy was I shocked - what a headache/ nightmare. Can you please update us? THANKS!!
     
  11. FLHT

    FLHT Medium Load Member

    436
    408
    Aug 2, 2014
    0
    06 Pete Cat powered 3 peddle gen 2 auto shift.
    Trans starts out by not wanting to up shift. After a while it will act like you turn on and off the key, light on dash blinks and red service light blinks.
    Next it falls out of gear with the up arrows and down arrows going off. Jumps back in gear and some times will not want to shift into 10th gear.
    Recently came off ramp and it would not down shifting now its stuck in high gear. Pulled over and shut down engine. After the green light on shifter went out I started it up with no problems.
    Also noted that it is less prone to do this when I am loaded heavy 44,000
    Anybody got any idea because Pete dealer don't have a clue.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted