eaton ultrashift auto, stuck in high range

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by wtokhi, Aug 8, 2022.

  1. wtokhi

    wtokhi Light Load Member

    218
    108
    Nov 3, 2017
    0
    hey everybody,
    got a 2015 cascadia with an auto eaton ultrashift 10 speed. unit came in for a clutch replacement and after the clutch was replaced, it passed calibration fine. upon moving the truck it dropped into reverse and showed R1 on the display, but moving in reverse it shuddered as if it was in a higher gear, rolling back i heard a shift and the display now read R3, weird, so i put it in drive and the display read 2, moving in 2 it did not accelerate and the rpm was bouncing like it was trying to shift, it does huge clunk and you can feel it slam into a gear and the display then reads 6, it shifts fine 6 to 10 but wont downshift from 6 and beeps if manually commanded until the ignition is cycled where it will do the same thing over. it has one code for spn 769 fmi 7, low range mechanical system not responding, in response to the code, i changed the range solenoid, the air regulator and the yoke bar and all the o-rings. same issue continued. Removed the rear section and saw the small splitter gear had worn teeth so i replaced it, with the rear section off the range yoke moves in and out but does require some tapping with a mallet, the splitter yoke moves in and out freely, put it back together and same issue, replaced splitter valve, same issues, replaced xy shifter and same issue occurs with the same code, at a loss at what it could be, any ideas? also to clairfy unit did not have this issue before the clutch replacement
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. baha

    baha Road Train Member

    4,099
    2,777
    Jul 25, 2013
    ga
    0
    You need to get it to move much easier than the hammer mentioned, look for a air pressure regulation valve standing up on top rear of your transmission, it was silver when it was new but when it gives wrong pressure the box can't shift for $$it
     
    BoxCarKidd Thanks this.
  4. wtokhi

    wtokhi Light Load Member

    218
    108
    Nov 3, 2017
    0
    the air regulator has been changed along with the solenoid, the mallet moved it easily and was movable by hand but required a tiny bit of force, could it be overcoming the vacuum pressure of the yoke bar? since its sealed air and there was no lubrication since the section was out
     
  5. baha

    baha Road Train Member

    4,099
    2,777
    Jul 25, 2013
    ga
    0
    Do you have the one that stands up between the shifter plate and back box bolts?
     
  6. baha

    baha Road Train Member

    4,099
    2,777
    Jul 25, 2013
    ga
    0
    It depends on what was replaced by rebuilder if you sent it off send it back, or look at the bushings and fix it with a adj. reamer to make it move free it doesn't have much air to make it move?
     
  7. wtokhi

    wtokhi Light Load Member

    218
    108
    Nov 3, 2017
    0
    CC0962FB-08D9-4111-8454-F898D61DC605.jpeg 91F872AA-51D7-4700-9516-EA4B043CB7D2.jpeg
    It was not sent off to get rebuilt as we didn’t find any issues with it, the parts highlighted in the diagram were replaced along with the yoke bar
     
    baha Thanks this.
  8. BoxCarKidd

    BoxCarKidd Road Train Member

    3,870
    5,507
    Aug 26, 2014
    0
    Tee in a gauge to the line on the low side range valve. Is the pressure correct? If it does not shift into low it is a mechanical problem. Or could it be some dirt got in a line or elbow? Check them out. Remove the high side line from the range cylinder. It could be holding pressure.
     
    baha Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted