Fuible link T600 location

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by jlawall, Apr 15, 2020.

  1. jlawall

    jlawall Light Load Member

    59
    9
    Jan 29, 2011
    wapwallopen pa
    0
    I have a no start situation on a T600 KW with an ISX. Good batteries and new starter but nothing on key on, not even clicking.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. 062

    062 Road Train Member

    4,924
    10,454
    Oct 20, 2013
    0
    Nothing with key on like am/fm blower motor? Check ignition fuse. If the radio and blower motor work, then the older ones had a relay. On the w900 it’s inside the battery box. @spsauerland @QUALITYTRUCK will hopefully be around later.
     
  4. spsauerland

    spsauerland Road Train Member

    3,853
    9,849
    May 31, 2010
    West Harrison, In
    0
    You check starter relay in battery box?
     
    062 Thanks this.
  5. jlawall

    jlawall Light Load Member

    59
    9
    Jan 29, 2011
    wapwallopen pa
    0
    Just getting back to this truck. Tapped starter with a hammer and it started. Brought it in and this afternoon started it and moved around locally here and backed into a dock to load and it shut off. Now the engine turns over but doesn't fire .. SOUNDS LIKE ITS OUT of fuel but both tanks are half full. Its a cummins ISX 2005 model. Not hearing the stepper pump pumping when turning key on.
     
  6. jlawall

    jlawall Light Load Member

    59
    9
    Jan 29, 2011
    wapwallopen pa
    0
     
  7. jlawall

    jlawall Light Load Member

    59
    9
    Jan 29, 2011
    wapwallopen pa
    0
    There is no relay in battery box on this truck. Ibelieve there is a relay over engine on the firewall. Does that have anything to do with stepper pump on ISX
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted